Bug 17812 - Kernel completely frozen when memory is full
Summary: Kernel completely frozen when memory is full
Status: CLOSED UNREPRODUCIBLE
Alias: None
Product: Memory Management
Classification: Unclassified
Component: Page Allocator (show other bugs)
Hardware: All Linux
: P1 blocking
Assignee: Andrew Morton
URL:
Keywords:
Depends on:
Blocks: 16055
  Show dependency tree
 
Reported: 2010-09-05 13:09 UTC by Mickey86
Modified: 2011-03-31 07:44 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.35.2
Tree: Mainline
Regression: Yes


Attachments
The .config file of my 2.6.35.2 custom kernel. (59.10 KB, text/plain)
2010-09-05 13:09 UTC, Mickey86
Details
Diff between my 2.6.35.2 config and 2.6.35.4 config (560 bytes, text/plain)
2010-09-09 06:22 UTC, Mickey86
Details

Description Mickey86 2010-09-05 13:09:50 UTC
Created attachment 29042 [details]
The .config file of my 2.6.35.2 custom kernel.

I use software that consume lot of memory, and since I changed for 2.6.35 kernel, when memory is full or nearly full the kernel stops without any message and all the system is completely frozen. Even the Magic System Key Requests are inoperant.

I used to compile the kernel myself (my .config file in attachment) for ages without this problem. This is 2.6.35 specific.

Note: I choose "page allocator" component but it can be another component.
Comment 1 Andrew Morton 2010-09-05 16:33:55 UTC
Bad.  Can you see if you can generate alt-sysrq-p and alt-sysrq-t traces when it's stuck?  Set CONFIG_MAGIC_SYSRQ=y, set /proc/sys/kernel/sysrq, run `dmesg -n 8', etc first?
Comment 2 Mickey86 2010-09-09 06:19:41 UTC
Since my last report I’ve changed 2.6.35.2 to 2.6.35.4 (compiled myself too, diff of configurations in attachment)… And I tried freeze it following your recommandations.

I have fulfilled all my 3 gio of memory, and it overflowed by 500 mio in SWAP space. But no luck, this time it hadn’t frozen the kernel.

I have deduced that the bug had left. So I stopped this test and emptied the memory (stopped the memory consuming programs). 

And in the following morning, I discovered my system frozen again; but I don’t know if the memory was fulfilled. Then I tried the key combination you gave me, but it had no effect: I’ve rebooted the system and had not found any trace file nor interesting lines in logs.

Note: my system is up all days and nights long, and it working hard on nights and large part of days (BOINC, so I never stop the system, it can run for days or months). But it never freezes in those span of time (except the night of the paragraph above, after the fulfil memory test), each time it has frozed I was in front of my system with the memory near (>98%) full.
Comment 3 Mickey86 2010-09-09 06:22:34 UTC
Created attachment 29402 [details]
Diff between my 2.6.35.2 config and 2.6.35.4 config
Comment 4 Florian Mickler 2010-09-30 06:43:46 UTC
I assume this hasn't been fixed yet in 2.6.35.7?

Do you by any chance are able to test on 2.6.36-rc6? 

Maybe you could set up a netconsole logging to catch any backtraces?
( see Documentation/networking/netconsole.txt, I found the "Dynamic Reconfiguration" chapter to be the easiest to set up)

Regards,
Flo
Comment 5 Florian Mickler 2011-03-30 22:25:30 UTC
Is this still a problem on 2.6.38.y?
Comment 6 Mickey86 2011-03-31 06:11:25 UTC
Better… Since I changed to 2.6.36 the problem had left.

In days or weeks, I would change to 2.6.38, if the problem is back I’ll report it again :)

Sorry for not having reported sooner that the problem had left. 

Thanks for the help!
Comment 7 Florian Mickler 2011-03-31 07:44:54 UTC
No problem. If it returns and _you are certain_ that it is the same problem, just poste a note / reopen the bug.

Thanks,
Flo

Note You need to log in before you can comment on or make changes to this bug.