Bug 177731 - Skylake gen6 suspend/resume video regression
Summary: Skylake gen6 suspend/resume video regression
Status: RESOLVED INVALID
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(AGP) (show other bugs)
Hardware: All Linux
: P1 high
Assignee: Dave Airlie
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-16 19:58 UTC by Pablo Cholaky
Modified: 2016-10-31 14:45 UTC (History)
2 users (show)

See Also:
Kernel Version: 4.9-rc1
Tree: Mainline
Regression: Yes


Attachments
Kernel config file (118.23 KB, application/octet-stream)
2016-10-16 19:58 UTC, Pablo Cholaky
Details
lshw (14.38 KB, text/plain)
2016-10-16 19:59 UTC, Pablo Cholaky
Details

Description Pablo Cholaky 2016-10-16 19:58:35 UTC
Created attachment 241821 [details]
Kernel config file

Intel suspend/resume regression is seen under Linux 4.9-rc1, and same config file under Linux 4.8 works fine.

Attaching my config file for 4.9. I recompilied 4.8 with this config file and no problem have been detected

I had this issue before at kernel 4.6, fixed on 4.7 or 4.8 (I don't remember), now is broken again at 4.9-rc1. The specific problem is the video doesn't turn on after resume. In past, this behavior happened after 2-3 suspensions, and may it be fixed with a couple of suspend/resume with a random screen fix. Now the video doesn't turn on after first suspension, and doesn't get back after doing multiple S3-S0.

I'm sorry to not be able to provide some better information, but I can do tests if you can tell me specifically what to do.
Comment 1 Pablo Cholaky 2016-10-16 19:59:00 UTC
Created attachment 241831 [details]
lshw
Comment 2 Zhang Rui 2016-10-25 05:46:38 UTC
please try the latest upstream kernel. a similar problem has been fixed in 4.9-rc2.
Comment 3 Pablo Cholaky 2016-10-25 14:07:31 UTC
(In reply to Zhang Rui from comment #2)
> please try the latest upstream kernel. a similar problem has been fixed in
> 4.9-rc2.

Hi Zhang, I tried with 4.9-rc2 and no luck, I got the computer frozen again. The screen doesn't turn on correctly. With 4.8 I don't have this problem.  There is some way I can obtain some useful info for debugging this kind of problems?
Comment 4 Thorsten Leemhuis 2016-10-30 11:20:01 UTC
JFYI: I added this report to the list of regressions for Linux 4.9. I'll watch this thread for further updates on this issue to document progress in my weekly reports. Please let me know via regressions@leemhuis.info in case the discussion moves to a different place (bugzilla or another mail thread for example). tia!

Latest messages on this issue: WIP

Ciao, Thorsten
Comment 5 Zhang Rui 2016-10-31 03:11:52 UTC
(In reply to Pablo Cholaky from comment #0)
> Created attachment 241821 [details]
> Kernel config file
> 
> Intel suspend/resume regression is seen under Linux 4.9-rc1, and same config
> file under Linux 4.8 works fine.
> 
> Attaching my config file for 4.9. I recompilied 4.8 with this config file
> and no problem have been detected
> 
> I had this issue before at kernel 4.6, fixed on 4.7 or 4.8 (I don't
> remember), now is broken again at 4.9-rc1. The specific problem is the video
> doesn't turn on after resume.

is the system still alive?
Say, can you ssh to the machine? is the keyboard still working?

> In past, this behavior happened after 2-3
> suspensions,

define "In past", kernel before 4.6? or 4.7/4.8?


> and may it be fixed with a couple of suspend/resume with a
> random screen fix. Now the video doesn't turn on after first suspension, and
> doesn't get back after doing multiple S3-S0.

Hah, I see, the system is still alive, but with a blank screen, right?
If yes, this is a graphics driver issue.
Please file a bug at freedesktop.org instead.
Comment 6 Pablo Cholaky 2016-10-31 04:21:30 UTC
(In reply to Zhang Rui from comment #5)
> (In reply to Pablo Cholaky from comment #0)
> > Created attachment 241821 [details]
> > Kernel config file
> > 
> > Intel suspend/resume regression is seen under Linux 4.9-rc1, and same
> config
> > file under Linux 4.8 works fine.
> > 
> > Attaching my config file for 4.9. I recompilied 4.8 with this config file
> > and no problem have been detected
> > 
> > I had this issue before at kernel 4.6, fixed on 4.7 or 4.8 (I don't
> > remember), now is broken again at 4.9-rc1. The specific problem is the
> video
> > doesn't turn on after resume.
> 
> is the system still alive?
> Say, can you ssh to the machine? is the keyboard still working?
> 
> > In past, this behavior happened after 2-3
> > suspensions,
> 
> define "In past", kernel before 4.6? or 4.7/4.8?

Works fine with 4.8, and it was broken at 4.6 but is broken again with 4.9-rc1 rc2 and now rc3 using almost same kernel config.
 
> > and may it be fixed with a couple of suspend/resume with a
> > random screen fix. Now the video doesn't turn on after first suspension,
> and
> > doesn't get back after doing multiple S3-S0.
> 
> Hah, I see, the system is still alive, but with a blank screen, right?
> If yes, this is a graphics driver issue.
> Please file a bug at freedesktop.org instead.

I don't think this is a intel X bug related, because the only change here to make it work or fail is the kernel version. Or you mean this should be matter of DRM team?
Comment 7 Jani Nikula 2016-10-31 14:45:32 UTC
Please file drm/i915 bugs at https://bugs.freedesktop.org/enter_bug.cgi?product=DRI&component=DRM/Intel

Note You need to log in before you can comment on or make changes to this bug.