Bug 17772 - Unable to locate IOAPIC for GSI *
Unable to locate IOAPIC for GSI *
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
All Linux
: P1 normal
Assigned To: platform_i386
:
Depends on:
Blocks: 16055
  Show dependency treegraph
 
Reported: 2010-09-04 21:28 UTC by Vasyl Demin
Modified: 2011-06-23 07:49 UTC (History)
7 users (show)

See Also:
Kernel Version: 2.6.35.4
Tree: Mainline
Regression: Yes


Attachments
Bootlog with "debug apic=debug" (29.08 KB, text/plain)
2010-09-13 20:28 UTC, Vasyl Demin
Details

Description Vasyl Demin 2010-09-04 21:28:37 UTC
Notebook: HP Compaq nx9020
OS: Arch Linux i686

After kernel upgrade up to 2.6.35 I see errors during boot:
ERROR: Unable to locate IOAPIC for GSI 8
ERROR: Unable to locate IOAPIC for GSI 13
ERROR: Unable to locate IOAPIC for GSI 1
ERROR: Unable to locate IOAPIC for GSI 12
Comment 1 Vasyl Demin 2010-09-13 20:28:05 UTC
Created attachment 29822 [details]
Bootlog with "debug apic=debug"
Comment 2 Avinash Kurup 2010-09-21 07:03:07 UTC
(In reply to comment #0)
> Notebook: HP Compaq nx9020
> OS: Arch Linux i686
> 
> After kernel upgrade up to 2.6.35 I see errors during boot:
> ERROR: Unable to locate IOAPIC for GSI 8
> ERROR: Unable to locate IOAPIC for GSI 13
> ERROR: Unable to locate IOAPIC for GSI 1
> ERROR: Unable to locate IOAPIC for GSI 12

Hi zersaa,
         I had faced this problem a while ago. This patch provided by Eric biederman solved the problem for me...check it and see if it works...
---

diff --git a/arch/x86/kernel/apic/io_apic.c b/arch/x86/kernel/apic/io_apic.c
index 33f3563..226a6d1 100644
--- a/arch/x86/kernel/apic/io_apic.c
+++ b/arch/x86/kernel/apic/io_apic.c
@@ -4066,6 +4066,9 @@ int acpi_get_override_irq(u32 gsi, int *trigger, int *polarity)
{
   int ioapic, pin, idx;

+    if (acpi_irq_model != ACPI_IRQ_MODEL_IOAPIC)
+        return -1;
+
   if (skip_ioapic_setup)
       return -1;
Comment 3 Sedat Dilek 2010-09-30 04:12:45 UTC
The original patch from Eric W. Biedermann is from [1]:

"Skip looking for ioapic overrides when ioapics are not present"

[1] https://patchwork.kernel.org/patch/104501/
Comment 4 Florian Mickler 2010-09-30 06:54:07 UTC
Patch: https://patchwork.kernel.org/patch/104501/

Seems this patch has fallen through the cracks.
Comment 5 Florian Mickler 2010-09-30 07:02:59 UTC
Switched to Email

On Thu, 30 Sep 2010 06:54:15 GMT
bugzilla-daemon@bugzilla.kernel.org wrote:

> https://bugzilla.kernel.org/show_bug.cgi?id=17772
> 
> 
> Florian Mickler <florian@mickler.org> changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>              Status|NEW                         |RESOLVED
>                  CC|                            |florian@mickler.org,
>                    |                            |mingo@elte.hu
>          Resolution|                            |PATCH_ALREADY_AVAILABLE
> 
> 
> 
> 
> --- Comment #4 from Florian Mickler <florian@mickler.org>  2010-09-30 06:54:07 ---
> Patch: https://patchwork.kernel.org/patch/104501/
> 
> Seems this patch has fallen through the cracks.
> 
I know, it's not an severe issue, but:

I couldn't find a patch to this effect in current mainline, is this
already queued? Or are there issues with the patch?

Poked-By: Florian Mickler <florian@mickler.org>
Comment 6 Rafael J. Wysocki 2010-10-03 21:23:22 UTC
Handled-By : Eric W. Biederman <ebiederm@xmission.com>
Comment 7 Vasyl Demin 2010-11-01 06:03:02 UTC
Sorry for long delay..

Patch works for me, thanks!
Comment 8 Florian Mickler 2011-03-30 22:24:23 UTC
Is this patch still needed on 2.6.38?
Comment 9 Sedat Dilek 2011-03-31 07:11:05 UTC
Thanks Florian for PINGing!

Debian has this patch (still) as "bugfix/x86/Skip-looking-for-ioapic-overrides-when-ioapics-are-not-present.patch" for so long time in its patch-series (months, a year?).

Here on my system you need to add "lapic" to boot-parameter to suppress:
[    0.008891] no APIC, boot with the "lapic" boot parameter to force-enable it.

(See discussion on "[PATCH] x86, perf, nmi: Disable perf if counters are not accessable" patch.)

An additional text to the original patch would be helpful to reflect "lapic".
Comment 10 Florian Mickler 2011-03-31 08:04:36 UTC
Ok, I sent it out to Andrew and cc'd people.. that should normally get it merged or at least we get some comment as to why it is out of tree.

Ingo is probably not reading this bug anymore. :(
Comment 11 Sedat Dilek 2011-03-31 08:11:57 UTC
Good.
I tried to convince GRML project to include this patch into 2010-12 release (and its kernel). I got a NOPE as they argued it is not in *mainline*. I contra-argued it is in Debian's patch-series (and GRML based on Debian). NOPE. OK, this is a somehow a "cosmetic" fix. But anyway, it will be nice to see it in mainly. BTW, [1] says "New Linux kernel version based on 2.6.36.2" :-). Might be good to CC stable.k.o?

[1] http://grml.org/changelogs/README-grml-2010.12/
Comment 12 Vasyl Demin 2011-06-23 07:49:59 UTC
Tested on 2.6.39.1
The patch is no longer needed.
Problem fixed, thanks!

Note You need to log in before you can comment on or make changes to this bug.