Bug 17762 - nfsd deadlock, 2.6.36-rc3
nfsd deadlock, 2.6.36-rc3
Status: CLOSED INVALID
Product: File System
Classification: Unclassified
Component: NFS
All Linux
: P1 normal
Assigned To: bfields
:
Depends on:
Blocks: 16444
  Show dependency treegraph
 
Reported: 2010-09-03 19:11 UTC by Maciej Rutecki
Modified: 2010-09-12 18:08 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.36-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-09-03 19:11:25 UTC
Subject    : nfsd deadlock, 2.6.36-rc3
Submitter  : Tim Gardner <tim.gardner@canonical.com>
Date       : 2010-09-01 15:39
Message-ID : 4C7E73CB.7030603@canonical.com
References : http://marc.info/?l=linux-kernel&m=128335681711984&w=2

This entry is being used for tracking a regression from 2.6.35. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Trond Myklebust 2010-09-03 19:22:07 UTC
To me that looks just like the usual deadlock scenario that is known to occur when the nfs server enters direct page reclaim on a loopback-mounted nfs client.

Reassigning to Bruce.
Comment 2 bfields 2010-09-03 20:00:19 UTC
Trond is correct, see followup in mailing list discussion.

Note You need to log in before you can comment on or make changes to this bug.