Bug 177291 - CONFIG_EEPROM_LEGACY causes very high interrupts on i801_smbus
Summary: CONFIG_EEPROM_LEGACY causes very high interrupts on i801_smbus
Status: RESOLVED DUPLICATE of bug 177311
Alias: None
Product: Drivers
Classification: Unclassified
Component: I2C (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: Jean Delvare
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-11 21:59 UTC by Conrad Kostecki
Modified: 2017-03-28 09:36 UTC (History)
1 user (show)

See Also:
Kernel Version: 4.8.1
Tree: Mainline
Regression: No


Attachments

Description Conrad Kostecki 2016-10-11 21:59:33 UTC
I've noticed, when I do enable CONFIG_EEPROM_LEGACY as a module or build into my kernel, this causes a very high rate of interrupts on i801_smbus - about 6000-8000 per second according to /proc/interrupts. After 20 minutes, there were about 5 million interrupts generated on i801_smbus.

When I do unload the module eeprom, the interrupts do not stop, until I do a complete reboot.

Mainboard: Supermicro A1SRM-2758F
Kernel: Gentoo-Sources 4.8.1 (Happens also with Vanilla 4.8.1 and older kernel versions)

dmesg:
[    9.213875] i801_smbus 0000:00:1f.3: enabling device (0140 -> 0143)
[    9.214014] i801_smbus 0000:00:1f.3: SMBus using PCI interrupt

lspci:
00:1f.3 SMBus: Intel Corporation Atom processor C2000 PCU SMBus (rev 02)
Comment 1 Conrad Kostecki 2017-03-23 17:12:02 UTC

*** This bug has been marked as a duplicate of bug 177311 ***

Note You need to log in before you can comment on or make changes to this bug.