Bug 17712 - lm_sensors returns wrong CPU temperature values with k8temp
Summary: lm_sensors returns wrong CPU temperature values with k8temp
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Hardware Monitoring (show other bugs)
Hardware: All Linux
: P1 low
Assignee: Jean Delvare
URL:
Keywords:
Depends on:
Blocks: 16055
  Show dependency tree
 
Reported: 2010-09-03 11:07 UTC by mkkot
Modified: 2010-09-25 11:43 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.35.4
Tree: Mainline
Regression: Yes


Attachments
dmesg (30.61 KB, text/plain)
2010-09-03 11:07 UTC, mkkot
Details

Description mkkot 2010-09-03 11:07:10 UTC
Created attachment 28942 [details]
dmesg

I kindly ask for indulgence as this is my first bugreport here.

I have a Gigabyte M61P-S3 motherboard with an AMD CPU installed:

model name      : AMD Athlon(tm) 64 X2 Dual Core Processor 5600+

I use cpu scaling feature if this matters (powernow-k8 cpufreq_ondemand). After recent kernel update (using Archlinux 64 bit packages):

[2010-09-01 11:01] upgraded kernel26 (2.6.34.1-1 -> 2.6.35.4-1)

my plasmoid which measures CPU core temperatures started to display very lowered values. After some digging I found it is probably using lm_sensors, which reports bad values as well:

[root@linux mk]# sensors
k8temp-pci-00c3
Adapter: PCI adapter
Core0 Temp:   +5.0°C                                    
Core0 Temp:   +6.0°C                                    
Core1 Temp:   +7.0°C                                    
Core1 Temp:   +2.0°C

[root@linux mk]# 

I should have there at least 27°C.

I use a standard often updated Archlinux system with no stange configuration or devices attached. Probably a dmesg output can tell you more.
Comment 1 Jean Delvare 2010-09-05 13:44:08 UTC
I believe this is caused by commit d535bad90dad4eb42ec6528043fcfb53627d4f89 (hwmon: (k8temp) Fix temperature reporting for ASB1 processor revisions), which affected more CPU models than was originally intended. Should be fixed by commit a05e93f3b3fc2f53c1d0de3b17019e207c482349 (hwmon: (k8temp) Differentiate between AM2 and ASB1) which limits the scope of the former commit to ASB1 models (I guess you have an AM2 model.)

The latter commit was already accepted by Greg KH for 2.6.32-stable and 2.6.35-stable, so you will get the fix when kernel 2.6.35.5 is released and your distribution upgrades to it.
Comment 2 Rafael J. Wysocki 2010-09-05 22:05:13 UTC
Fixed in the mainline, so closing.
Comment 3 mkkot 2010-09-25 11:43:17 UTC
Thanks, it works in 2.6.35.5.

Note You need to log in before you can comment on or make changes to this bug.