Bug 17461 - WARNING at fs/fs-writeback.c:972 __mark_inode_dirty+0x1d4/0x1e0()
WARNING at fs/fs-writeback.c:972 __mark_inode_dirty+0x1d4/0x1e0()
Status: CLOSED DUPLICATE of bug 16312
Product: File System
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Jan Kara
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-30 14:58 UTC by Larry Finger
Modified: 2010-09-20 16:18 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.36-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Larry Finger 2010-08-30 14:58:04 UTC
On bootup, I get the following warning logged:

[   12.192109] ------------[ cut here ]------------
[   12.192118] WARNING: at fs/fs-writeback.c:972
__mark_inode_dirty+0x1d4/0x1e0()
[   12.192122] Hardware name: HP Pavilion dv2700 Notebook PC
[   12.192124] bdi-block not registered
[   12.192126] Modules linked in: loop(+) dm_mod ide_cd_mod cdrom
snd_hda_codec_conexant ide_pci_generic snd_hda_intel snd_hda_codec r8712u(C)
amd74xx snd_pcm ide_core snd_timer snd k8temp sg joydev snd_page_alloc
forcedeth hwmon i2c_nforce2 serio_raw i2c_core battery ac button ext3 jbd
mbcache ohci_hcd sd_mod ehci_hcd usbcore fan processor ahci libahci libata
scsi_mod thermal
[   12.192164] Pid: 2338, comm: udisks-part-id Tainted: G         C 
2.6.36-rc3-realtek+ #7
[   12.192167] Call Trace:
[   12.192174]  [<ffffffff8104614a>] warn_slowpath_common+0x7a/0xb0
[   12.192178]  [<ffffffff81046221>] warn_slowpath_fmt+0x41/0x50
[   12.192183]  [<ffffffff81325584>] ? _raw_spin_lock+0x34/0x40
[   12.192186]  [<ffffffff8112ded5>] ? __mark_inode_dirty+0x65/0x1e0
[   12.192190]  [<ffffffff8112e044>] __mark_inode_dirty+0x1d4/0x1e0
[   12.192195]  [<ffffffff811210bd>] touch_atime+0x12d/0x170
[   12.192201]  [<ffffffff810cbb61>] generic_file_aio_read+0x5c1/0x720
[   12.192205]  [<ffffffff810e7fbd>] ? handle_mm_fault+0x75d/0x950
[   12.192211]  [<ffffffff8110a862>] do_sync_read+0xd2/0x110
[   12.192214]  [<ffffffff8107a4a0>] ? mark_held_locks+0x70/0xa0
[   12.192218]  [<ffffffff8132436f>] ? __mutex_unlock_slowpath+0xbf/0x150
[   12.192222]  [<ffffffff8107a6cd>] ? trace_hardirqs_on+0xd/0x10
[   12.192226]  [<ffffffff8110af93>] vfs_read+0xc3/0x170
[   12.192229]  [<ffffffff8110b08c>] sys_read+0x4c/0x80
[   12.192234]  [<ffffffff81002d2b>] system_call_fastpath+0x16/0x1b
[   12.192237] ---[ end trace 9b3df7d4a57af8dc ]---
[   12.198091] loop: module loaded

The kernel is a fresh pull from linux-2.6.git with some code added to staging for an RTL8192 USB device.
Comment 1 Tejun Heo 2010-09-01 09:31:01 UTC
Jan, is this related to the block bdi thing we talked about before?  Thanks.
Comment 2 Jan Kara 2010-09-01 11:11:48 UTC
Yes, this seems exactly like the problem you were fixing...
Comment 3 Jan Kara 2010-09-01 11:12:58 UTC
PS: I'm sorry, I've got sidetracked with other work so I didn't try pushing your fix yet.
Comment 4 Tejun Heo 2010-09-01 11:31:47 UTC
Ah... good.  I completely forgot what the original issue was and can't find the thread now.  It was related to block layer bdi not ready for writeback or some such, right?  Can you please give me a pointer?

Thanks.
Comment 5 Jan Kara 2010-09-01 11:38:31 UTC
Larry, this seems like a duplicate of bug 16312. So are you running with Tejun's fix from that bug? From your initial comment it seems you don't...
Comment 6 Larry Finger 2010-09-01 13:56:04 UTC
Tejun's patch entitles "sd-delay-uevent" does not fix the problem. With it, I warm rebooted 3 times without the problem, but got the warning with a cold boot. As it is intermittent, I do not know if that is significant.

I will be going off-line today for about 60 days. Perhaps someone else will turn up with this warning and they will be able to test. If not, I'll be back in November.
Comment 7 Jan Kara 2010-09-20 10:20:33 UTC

*** This bug has been marked as a duplicate of bug 16312 ***

Note You need to log in before you can comment on or make changes to this bug.