Bug 1741 - Asus PR-DLS533 motherboard PCI problem
Asus PR-DLS533 motherboard PCI problem
Status: REJECTED DUPLICATE of bug 1662
Product: ACPI
Classification: Unclassified
Component: BIOS
i386 Linux
: P2 normal
Assigned To: Shaohua
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-24 01:32 UTC by Andreas Haumer
Modified: 2004-04-22 13:16 UTC (History)
0 users

See Also:
Kernel Version: 2.4.23, 2.4.24-pre2
Tree: Mainline
Regression: ---


Attachments
Output of acpidmp (79.66 KB, text/plain)
2003-12-24 01:34 UTC, Andreas Haumer
Details
/proc/interrupts (with pci=noacpi) (768 bytes, text/plain)
2003-12-24 01:36 UTC, Andreas Haumer
Details
lspci -v (with pci=noacpi) (4.05 KB, text/plain)
2003-12-24 01:38 UTC, Andreas Haumer
Details
kernel boot messages (pci=noacpi) (19.21 KB, text/plain)
2003-12-24 01:40 UTC, Andreas Haumer
Details
/proc/interrupts (full acpi) (622 bytes, text/plain)
2003-12-24 01:42 UTC, Andreas Haumer
Details
lspci -v (full acpi) (2.40 KB, text/plain)
2003-12-24 01:43 UTC, Andreas Haumer
Details
kernel boot messages (full acpi) (19.48 KB, text/plain)
2003-12-24 01:48 UTC, Andreas Haumer
Details

Description Andreas Haumer 2003-12-24 01:32:11 UTC
Distribution: xS+S BLD
Hardware Environment: Asus AP1700-S5 server with dual Xeon 2.8GHz
(This bug seems to be similar to bug #1662, but with slightly different hardware)

Booting the system with an ACPI enabled kernel, the built-in Fusion MPT driver
does not find the LSI Logic 53c1030 PCI-X Fusion-MPT U320 SCSI controller.
I have to boot with "acpi=off" or "pci=noacpi" to get the SCSI hardware
recognized. Verified with 2.4.21-ac (ACPI revision 20030522), 2.4.23, 2.4.24-pre2
Upgraded to most current BIOS (2GBL1009, from Dec. 15th, 2003), but problem
persists.
Comment 1 Andreas Haumer 2003-12-24 01:34:12 UTC
Created attachment 1733 [details]
Output of acpidmp
Comment 2 Andreas Haumer 2003-12-24 01:36:34 UTC
Created attachment 1734 [details]
/proc/interrupts (with pci=noacpi)

Output from cat /proc/interrupts on kernel 2.4.24-pre2 booted with "pci=noacpi"
Comment 3 Andreas Haumer 2003-12-24 01:38:43 UTC
Created attachment 1735 [details]
lspci -v (with pci=noacpi)

Output of "lspci -v" on kernel 2.4.24-pre2 booted with "pci=noacpi"
Comment 4 Andreas Haumer 2003-12-24 01:40:16 UTC
Created attachment 1736 [details]
kernel boot messages (pci=noacpi)

boot messages from kernel 2.4.24-pre2 booted with "pci=noacpi"
Comment 5 Andreas Haumer 2003-12-24 01:42:36 UTC
Created attachment 1737 [details]
/proc/interrupts (full acpi)

This is the output of "cat /proc/interrupts" for kernel 2.4.21-ac with full
acpi enabled
Comment 6 Andreas Haumer 2003-12-24 01:43:38 UTC
Created attachment 1738 [details]
lspci -v (full acpi)

This is the output of "lspci -v" for kernel 2.4.21-ac with full acpi enabled
Comment 7 Andreas Haumer 2003-12-24 01:48:17 UTC
Created attachment 1739 [details]
kernel boot messages (full acpi)

These are the boot messages for kernel 2.4.21-ac with full acpi enabled (sorry
for the mix of kernel versions, but I have to use my rescue floppy to provide
infos with full acpi, and I do not have a bootable floppy set for newer kernels
yet)
Comment 8 Shaohua 2003-12-24 23:37:34 UTC
according to the acpidmp, it's same problem as bug #1662. all pci root bridges 
_BBN method incorrectly returns 0 , which means in ACPI mode, all pci root 
bridges will have bus number 0. So, some PCI devices can't be found or work.
Comment 9 Luming Yu 2003-12-29 18:55:53 UTC
According to ACPI spec 6.5.5 _BBN (Base bus number):
 For muti-root PCI machines, _BBN is PCI bus number that BIOS assigns. This
is needed to access a PCI_CONFIG operation region for the specific bus. The 
BBN must be unique for every host bridge within a segment since it is the PCI 
bus number.


--Luming
Comment 10 Andreas Haumer 2003-12-30 04:18:31 UTC
Thanks for your comments!
So, this is essentially a BIOS bug without workaround and should be reported to
Asus?
If so, can I use your comments and reference to the ACPI spec to
describe the problem?
Comment 11 Shaohua 2004-01-08 18:37:47 UTC

*** This bug has been marked as a duplicate of 1662 ***

Note You need to log in before you can comment on or make changes to this bug.