Bug 17371 - Total freeze at boot
Summary: Total freeze at boot
Status: RESOLVED DUPLICATE of bug 17361
Alias: None
Product: Memory Management
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Andrew Morton
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-29 20:11 UTC by Christian Casteyde
Modified: 2010-09-22 18:11 UTC (History)
0 users

See Also:
Kernel Version: 2.6.36-rc2
Tree: Mainline
Regression: Yes


Attachments
screenshot after the bug (350.42 KB, image/jpeg)
2010-08-29 20:11 UTC, Christian Casteyde
Details
first freeze (337.08 KB, image/jpeg)
2010-09-14 05:59 UTC, Christian Casteyde
Details
second freeze (418.78 KB, image/jpeg)
2010-09-14 06:01 UTC, Christian Casteyde
Details

Description Christian Casteyde 2010-08-29 20:11:20 UTC
Created attachment 28371 [details]
screenshot after the bug

Kernel 2.6.36-rc3
Athlon 64X2 3GHz in 64 bits mode
Slackware64 13.1

Since kernel 2.6.36-rc2 (and maybe -rc1), sometime the kernel freezes totally at boot. The kernel is compiled with kmemcheck, deadlock detection, etc.
I've got a photo on -rc3, since I cannot save anything when that happens.

Basically, its confusing, there is a warning, a:
BUG: sleeping function called on invalid context at mm/mmap.c: 232
and a general protection fault, to terminate with a panic - exception in interrupt.
The call stack doesn't appeared after the crash.

I've appended the photo if it can help.
This occurs roughly one boot every ten.
Comment 1 Christian Casteyde 2010-09-14 05:58:48 UTC
Still present in 2.6.36-rc4
I've got two more screenshots (the end of the oops, before freeze)
Comment 2 Christian Casteyde 2010-09-14 05:59:53 UTC
Created attachment 29882 [details]
first freeze
Comment 3 Christian Casteyde 2010-09-14 06:01:03 UTC
Created attachment 29892 [details]
second freeze
Comment 4 Christian Casteyde 2010-09-22 18:11:39 UTC
Maybe the same as https://bugzilla.kernel.org/show_bug.cgi?id=17361
At least I haven't seen these call stacks (with scsi...) with -rc5, so closing.
17361 is just enough.

*** This bug has been marked as a duplicate of bug 17361 ***

Note You need to log in before you can comment on or make changes to this bug.