Bug 17341 - kdump regression compared to v2.6.35
kdump regression compared to v2.6.35
Status: CLOSED CODE_FIX
Product: Other
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: other_other
:
Depends on:
Blocks: 16444
  Show dependency treegraph
 
Reported: 2010-08-29 14:11 UTC by Maciej Rutecki
Modified: 2010-09-21 00:22 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.36-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-08-29 14:11:14 UTC
Subject    : kdump regression compared to v2.6.35
Submitter  : CAI Qian <caiqian@redhat.com>
Date       : 2010-08-27 12:35
Message-ID : 2136707099.1405541282912500148.JavaMail.root@zmail06.collab.prod.int.phx2.redhat.com
References : http://marc.info/?l=linux-kernel&m=128291252612135&w=2

This entry is being used for tracking a regression from 2.6.35. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2010-08-29 22:04:28 UTC
Handled-By : Tejun Heo <tj@kernel.org>
Comment 2 Rafael J. Wysocki 2010-09-21 00:20:57 UTC
On Tuesday, September 21, 2010, caiqian@redhat.com wrote:
> It had been fixed by Tejun already.
> 
> commit 477a3c33d1efa0342a74bd02da2e049191993e2c
> Author: Tejun Heo <tj@kernel.org>
> Date:   Tue Aug 31 10:54:35 2010 +0200
> 
>     workqueue: fix GCWQ_DISASSOCIATED initialization
>     
>     init_workqueues() incorrectly marks workqueues for all possible CPUs
>     associated.  Combined with mayday_mask initialization bug, this can
>     make rescuers keep trying to bind to an offline gcwq indefinitely.
>     Fix init_workqueues() such that only online CPUs have their gcwqs have
>     GCWQ_DISASSOCIATED cleared.

Note You need to log in before you can comment on or make changes to this bug.