Bug 17331 - BUG: scheduling while atomic
BUG: scheduling while atomic
Status: CLOSED UNREPRODUCIBLE
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake
All Linux
: P1 normal
Assigned To: acpi_power-sleep-wake
:
Depends on:
Blocks: 7216 16444
  Show dependency treegraph
 
Reported: 2010-08-29 14:03 UTC by Maciej Rutecki
Modified: 2010-09-14 08:38 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.36-rc2-git4
Tree: Mainline
Regression: Yes


Attachments
[debug patch] use the Preemptible to check whether the cond_schedule should be called (836 bytes, patch)
2010-09-08 07:16 UTC, ykzhao
Details | Diff

Description Maciej Rutecki 2010-08-29 14:03:10 UTC
Subject    : BUG: scheduling while atomic
Submitter  : Sergey Senozhatsky <sergey.senozhatsky@gmail.com>
Date       : 2010-08-27 7:59
Message-ID : 20100827075911.GA5966@swordfish.minsk.epam.com
References : http://marc.info/?l=linux-kernel&m=128289602925505&w=2

This entry is being used for tracking a regression from 2.6.35. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Len Brown 2010-08-31 02:19:24 UTC
> snapshot_ioctl: ioctl '80083307' is deprecated and will be removed \
> soon, update your suspend-to-disk utilities 

What happens when you use the latest version of s2disk?
Comment 2 Sergey Senozhatsky 2010-08-31 08:23:22 UTC
On (08/31/10 02:20), bugzilla-daemon@bugzilla.kernel.org wrote:
> https://bugzilla.kernel.org/show_bug.cgi?id=17331
> 
> 
> > snapshot_ioctl: ioctl '80083307' is deprecated and will be removed \
> > soon, update your suspend-to-disk utilities 
> 
> What happens when you use the latest version of s2disk?
> 

Hello,
I'm running Arch Linux

pm-utils 1.4.0-1 (which is the latest stable release according to 
http://pm-utils.freedesktop.org/wiki/)

s2disk -V
s2disk (suspend) 0.8

uswsusp 0.8-6 (which is the latest stable release according to
http://suspend.sourceforge.net/)


	Sergey
Comment 3 ykzhao 2010-09-08 07:16:25 UTC
Created attachment 29252 [details]
[debug patch] use the Preemptible to check whether the cond_schedule should be called

Hi, Sergey
    Will you please try the latest linux master tree and see whether the issue still exists?

    If it exists, will you please try the attached debug patch and see whether it is helpful?

Thanks.
Comment 4 Sergey Senozhatsky 2010-09-13 10:55:20 UTC
On (09/08/10 07:16), bugzilla-daemon@bugzilla.kernel.org wrote:
> Hi, Sergey
>     Will you please try the latest linux master tree and see whether the issue
> still exists?
> 
>     If it exists, will you please try the attached debug patch and see whether
> it is helpful?
> 
> Thanks.

Hello,
Can't reproduce with 2.6.36-rc4. Seems to be fixed.


	Sergey
Comment 5 Len Brown 2010-09-14 01:29:43 UTC
Thanks for confirming that...

2.6.36-rc2-git3 worked
2.6.36-rc2-git4 failed
2.6.36-rc4 works

since this doesn't appear in any actual release,
i'll assume some other issue in the early rc2 caused
it and it is now gone.  Please re-open if you see this again.
Comment 6 Sergey Senozhatsky 2010-09-14 08:38:04 UTC
On (09/14/10 01:29), bugzilla-daemon@bugzilla.kernel.org wrote:
> --- Comment #5 from Len Brown <lenb@kernel.org>  2010-09-14 01:29:43 ---
> Thanks for confirming that...
> 
> 2.6.36-rc2-git3 worked
> 2.6.36-rc2-git4 failed
> 2.6.36-rc4 works
> 
> since this doesn't appear in any actual release,
> i'll assume some other issue in the early rc2 caused
> it and it is now gone.  Please re-open if you see this again.
> 

Sure. Thanks.

	Sergey

Note You need to log in before you can comment on or make changes to this bug.