Bug 1730 - S4 no suspend, S3 no resume -- Sony vaio z1
S4 no suspend, S3 no resume -- Sony vaio z1
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake
i386 Linux
: P2 normal
Assigned To: Len Brown
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-22 19:43 UTC by Nils Spengler
Modified: 2004-11-10 12:04 UTC (History)
8 users (show)

See Also:
Kernel Version: 2.6.0
Tree: Mainline
Regression: ---


Attachments
kernel config (25.79 KB, text/plain)
2003-12-22 19:45 UTC, Nils Spengler
Details
dmesg output (15.13 KB, text/plain)
2003-12-22 19:47 UTC, Nils Spengler
Details
dsdt (13.55 KB, application/octet-stream)
2003-12-22 19:48 UTC, Nils Spengler
Details
dmesg -s40000 (12.21 KB, text/plain)
2004-01-24 22:25 UTC, Olaf Krische
Details
dmidecode (6.42 KB, text/plain)
2004-01-24 22:25 UTC, Olaf Krische
Details
acpidmp (71.71 KB, application/octet-stream)
2004-01-24 22:26 UTC, Olaf Krische
Details
lspci -vvv (9.90 KB, text/plain)
2004-01-24 22:27 UTC, Olaf Krische
Details
cat /proc/interrupts (521 bytes, text/plain)
2004-01-24 22:28 UTC, Olaf Krische
Details

Description Nils Spengler 2003-12-22 19:43:21 UTC
Distribution: gentoo linux 1.4

Hardware Environment: sony vaio pcg-z1sp

Problem Description: suspend to disk and suspend to ram does not work on sony
vaio z1 series notebooks. when trying to suspend to disk i get absolutely no
reaction. when trying to suspend to ram, it obviously suspends. the components
(hdd, screen, fan ...) turns off and the green power led begins to flash red
(just like it does in windows). but when trying to reactivate, it gives no
reaction. only the battery led turns on. you have to remove the battery and the
ac adaptor to bring it to live again. pressing the power buttons a few seconds
does not work. i have the latest bios installed.
Comment 1 Nils Spengler 2003-12-22 19:45:17 UTC
Created attachment 1714 [details]
kernel config
Comment 2 Nils Spengler 2003-12-22 19:47:02 UTC
Created attachment 1715 [details]
dmesg output
Comment 3 Nils Spengler 2003-12-22 19:48:08 UTC
Created attachment 1716 [details]
dsdt
Comment 4 Len Brown 2004-01-08 19:11:33 UTC
> ACPI: (supports S0 S3 S4 S5) 
 
so S4 doesn't suspend 
and S3 suspends, but doesn't resume. 
 
> ACPI: Subsystem revision 20031203 
>   tbget-0291: *** Info: Table [DSDT] replaced by host OS 
 
Is the DSDT attached the original, or the modified version? 
 
 
Comment 5 Nils Spengler 2004-01-08 22:34:37 UTC
it's the modified. but i get the same results with both.
Comment 6 Nils Spengler 2004-01-09 01:02:12 UTC
btw, the default one compiled fine, so i assume that the original one is the
correct one.
Comment 7 Olaf Krische 2004-01-24 22:22:03 UTC
System: sony pcg-z1rsp

Using Debian testing/unstable with kernel 2.6.2-rc1-mm2

I have nearly the same symptoms like described here. 

First:

S3 and S4 will suspend, but no resume is possible. I always have
to pull out power cable and the battery to bring the notebook back to
life.

Second:

The system will not poweroff, when doing a shutdown. I get a message like this:

acpi_power_off called
hwsleep-0265 [19541] acpi_enter_sleep_state: Entering Sleep State [S5]

I have to power it off "manually" with pushing the powerbutton a few seconds
Comment 8 Olaf Krische 2004-01-24 22:25:02 UTC
Created attachment 1947 [details]
dmesg -s40000
Comment 9 Olaf Krische 2004-01-24 22:25:58 UTC
Created attachment 1948 [details]
dmidecode
Comment 10 Olaf Krische 2004-01-24 22:26:57 UTC
Created attachment 1949 [details]
acpidmp
Comment 11 Olaf Krische 2004-01-24 22:27:44 UTC
Created attachment 1950 [details]
lspci -vvv
Comment 12 Olaf Krische 2004-01-24 22:28:21 UTC
Created attachment 1951 [details]
cat /proc/interrupts
Comment 13 Nils Spengler 2004-01-25 09:02:53 UTC
disable local apic support in the kernel to get the machine shutting down properly.
Comment 14 Olaf Krische 2004-01-26 13:10:32 UTC
Okay. I disabled local apic. PowerOff is working fine now. Thanks!

Btw. when i suspend to RAM, the powerbutton flashes red, as in windows, when the
standby is done there. As soon as i push any button, the flashing disappears and
the laptop will not react anymore. So, i assume, the suspend is working, but not
the wakeup.

no chat, i know :)
Comment 15 Rolf Offermanns 2004-01-31 19:19:32 UTC
I had the same problem with my IBM Thinkpad R40 2681CDG.
After applying patches from bug #1415 and #1661 the S3 stuff works for me now.
However S4 still does absolutely nothing.
poweroff has always worked, besides bug #1987 (if that is a bug...)
Comment 16 Nicolas Brouard 2004-05-07 09:46:23 UTC
I have a Sony Z1RMP with exactly the same symptoms. I am running Mandrake 10.0
official which is 2.6.4 kernel. A simple echo 3 >/proc/acpi/sleep gives suspend
mode with a flashing power button like on Windows. But if you touch  the
keyboard the flashing freezes and you can get anymore from the screen which is
still black.
Then you have to unplug the battery and to get back working.

What can we do? We don't have access to any information. I read that it could be
due to some interaction from video card with bios, but I hope that Sony
extracted most things from bios and that the problem might be simpler and
similar to bug 1415 with IBM...
Comment 17 Pokey the Penguin 2004-05-11 02:20:26 UTC
After suspending to disk, the power light blinks. Upon pressing the power button
or a key, the light stops blinking and I have to reset the Z1RMP by removing the
battery.

This bug is blocking a deployment of Linux on laptops at my workplace -- can I
contribute financially/otherwise towards a fix?
Comment 18 Edd Dumbill 2004-05-12 03:45:29 UTC
Also experiencing this on a Sony Vaio TR1 MP, kernel 2.6.6.  After entering S3,
power light flashes red.  On pressing power button to resume, the power light
comes on solid green, and the battery light solid orange.  The machine is
unresponsive, and battery and power must be disconnected to get the machine to boot.
Comment 19 Venkatesh Pallipadi 2004-11-03 18:37:42 UTC
Is the S3 problem still there with latest 2.6 kernel?

If yes, can you make sure whether the problem is only with restore of the 
video (try connecting through network or serial after resume).

If it is only the video problem, 
- Please try the options in Documentation/power/video.txt
- Try the workaround in bug #3670
Comment 20 Edd Dumbill 2004-11-04 02:43:19 UTC
Mixed results. 2.6.9 resumes OK, but it doesn't reinitialise the video, not even
with the hacks in Documentation/power/video.txt.  If I try the video_post I get
a scary display on the LCD panel: a white fog with red green and blue thin
vertical lines.
Comment 21 Venkatesh Pallipadi 2004-11-04 06:55:10 UTC
Are you using X or the framebuffer?
Can you try video_post with normal VGAtext console (deCONFIGure framebuffer in 
your kernel)?
Comment 22 Edd Dumbill 2004-11-04 07:17:53 UTC
Yep.  Tried from both X and the console.  I'm not using the framebuffer.
The TR1 MP has an i855 video chip.
Comment 23 Olaf Krische 2004-11-07 07:22:46 UTC
With kernel 2.6.9, echo 3 > /proc/acpi/sleep and waking up with the 'video_post'
tool, as mentioned in bug #3670, works for me so far. 

It feels like just switching off, so fast it switches to sleep, incredible :D

But all of my external usb devices are dead after waking up. I use the notebook
in a docking station, with a usb keyboard and mice. They wont work anymore after
waking up. But this seems to be another topic, i guess.

Does anyone know how to wake up the usb devices again?

And to bitch a bit about sony: when the notebook is in the docking station and
the lid is closed, how can i wake up the notebook without opening the lid?
Grrrr. :-)

Thanks!
Comment 24 Venkatesh Pallipadi 2004-11-09 07:29:37 UTC
For everyone having ATI-Radeon Video card on their Sony vaio, video hacks in 
#3670 will help. For USB issue, usb-uhci normally works for me with suspend-
resume. But usb-ehci doesn't. If it doesn;t work for you, try unloading the 
usb modules at suspend time and reload it after resume.

Now, for Sony vaio with Intel video (Edd), couple of things you may want to try
- acpi_sleep=s3_bios,s3_mode with text console (IIRC, it fixed the issue with 
Sony VAIO Z600/Z505. Not sure whether it is the same laptop)
- And with X, can you try VBERestore workaround mentioned in bug #3177. 

Comment 25 Edd Dumbill 2004-11-09 11:22:38 UTC
> acpi_sleep=s3_bios,s3_mode with text console

does not work with Sony TR1MP

>And with X, can you try VBERestore workaround mentioned in bug #3177. 

this works!  although now the console display is odd -- it has horizontal black
lines running up and down it flickering

Comment 26 Venkatesh Pallipadi 2004-11-09 17:36:54 UTC
Thats good news :)

Did you try all the things mentioined in bug #3177. I think if you do all 
this, you may get luckier and get the text console working too :-)

(1) Add this option to my X config:
    Option          "VBERestore"            "true"

(2) suspend script does:
    chvt 7
    chvt 1
    chvt 7

(3) using vga16fb and the two acpi kernel command options. 

Comment 27 Edd Dumbill 2004-11-09 17:58:31 UTC
Using vga16fb solved the problem of flickering console.

Additional to that I just used the X config
   Option          "VBERestore"            "true"

and the chvt instructions.

I did not need the acpi_sleep kernel boot options.

many thanks for your help
Comment 28 Venkatesh Pallipadi 2004-11-09 18:52:36 UTC
Len This bug can be closed now.


Sony VAIO laptops summary:
Systems with Intel graphic cards.. look for comment #27 (and also bug #3177)

Systems with ATI graphic cards look for cmment #23 (and also bug #3670)

Note You need to log in before you can comment on or make changes to this bug.