Bug 1721 - S3 resume hangs -- fujitsu-siemens e6624
Summary: S3 resume hangs -- fujitsu-siemens e6624
Status: REJECTED DUPLICATE of bug 3670
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake (show other bugs)
Hardware: i386 Linux
: P2 low
Assignee: Len Brown
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-12-21 17:04 UTC by boldizsar bencsath
Modified: 2004-11-06 17:05 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.0 final
Tree: Mainline
Regression: ---


Attachments
dmesg from 2.6.0 loading... (22.70 KB, text/plain)
2003-12-21 17:13 UTC, boldizsar bencsath
Details

Description boldizsar bencsath 2003-12-21 17:04:56 UTC
Distribution: debian, unstable
Hardware Environment: fujitsu-siemens lifebook (notebook) E-6624 (intel 830, 
pIII-933, radeon m6)
Software Environment: debian. windows (98,2000,xp) is o.k. with acpi.
Problem Description:

first, thank you, the kernel oops from acpi are eliminated at 2.6.0testX, but:
doing an "echo 3>/proc/acpi/sleep" sleeps the notebook well, the small lcd 
panel shows the blinking power icon to indicate this.
If I press the power button to wake up, it starts to use the disk, and pccards 
(as shown on this small lcd display), and it is waken up (as the power icon 
does not blink any more), but braindead: no display, no keyboard, no network, 
so it hangs.

the same happened (happening) in apm, my only goal is to solve somehow to be 
able to do suspend-to-ram... but currently both acpi and apm do not work.


I tried the patch mentioned in a previous bug (1488?) (which enumerates 
devices in /proc/acpi/wakeup_devices or something, and put echo "LID" 
>/proc/acpi/wakeup_devices, no success.

how to debug ?


Steps to reproduce:

load the kernel, echo "3" >/proc/acpi/sleep. press the power button.
Comment 1 boldizsar bencsath 2003-12-21 17:13:41 UTC
Created attachment 1709 [details]
dmesg from 2.6.0 loading...

hope you find any idea..
Comment 2 Georg Greve 2004-02-08 07:39:20 UTC
is there possibly a relation to http://bugzilla.kernel.org/show_bug.cgi?id=1877 ?

The i830 agp code is also used for the Intel 855GM chipset, apparently.
Comment 3 Venkatesh Pallipadi 2004-11-03 18:35:41 UTC
Is the problem still there with latest 2.6 kernel?

If yes, can you make sure whether the problem is only with restore of the 
video (try connecting through network or serial after resume).

If it is only the video problem, 
- Please try the options in Documentation/power/video.txt
- Try the workaround in bug #3670
Comment 4 boldizsar bencsath 2004-11-05 17:00:48 UTC
Yes, 2.6.8.1 is resuming without video (network access from the outside is ok.
after resume). I've also tested this on older kernels and there were no such
'good' results. After all your notes and
http://www.doesi.gmxhome.de/linux/tm800s3/s3.html
is really good, 
http://www.doesi.gmxhome.de/linux/tm800s3/resources/boot-radeon.c
almost does the job but it leaves the video in 80x24 but linux thinks it is
80x50 or something, so a 
sleep 2;SVGATextMode -a -o  refines the resume process.

I did not check it in X, but a dream already came true...
Comment 5 Venkatesh Pallipadi 2004-11-05 17:06:56 UTC
Good :).. 
You can push your luck further with the vgapost utility in bug #3670. If the 
user utility works, also try the kernel patch there and you should have X 
working too..
Comment 6 Len Brown 2004-11-05 18:02:48 UTC

*** This bug has been marked as a duplicate of 3670 ***
Comment 7 boldizsar bencsath 2004-11-06 17:05:07 UTC
X is also o.k. with
http://www.doesi.gmxhome.de/linux/tm800s3/s3.html (script somewhat modified)
and
http://www.doesi.gmxhome.de/linux/tm800s3/resources/boot-radeon.c
and an SVGATextMode -a -o.

Now my problem is revitalizing ethernet card - after suspend in X it cannot
reach the network 'some times' - it means the first impessions showed that
netrok is o.k. from outside but now it feels that it is not available from
inside-out.

Anyhow. 2.8.1 + boot-radeon rocks.

Note You need to log in before you can comment on or make changes to this bug.