Bug 17131 - WARN with 3c905 boomerang NIC
WARN with 3c905 boomerang NIC
Status: CLOSED DUPLICATE of bug 18492
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 normal
Assigned To: drivers_network@kernel-bugs.osdl.org
:
Depends on:
Blocks: 16444
  Show dependency treegraph
 
Reported: 2010-08-26 18:31 UTC by Maciej Rutecki
Modified: 2010-09-20 18:55 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.36-rc1
Tree: Mainline
Regression: Yes


Attachments
Proposed patch (1.08 KB, patch)
2010-09-02 18:43 UTC, Paul E. McKenney
Details | Diff

Description Maciej Rutecki 2010-08-26 18:31:26 UTC
Subject    : WARN with 3c905 boomerang NIC
Submitter  : Doug Nazar <nazard.lkml@gmail.com>
Date       : 2010-08-22 6:35
Message-ID : 4C70C516.5020404@gmail.com
References : http://marc.info/?l=linux-kernel&m=128245894300623&w=2

This entry is being used for tracking a regression from 2.6.35. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2010-08-29 22:29:33 UTC
Handled-By : David Miller <davem@davemloft.net>
Comment 2 Paul E. McKenney 2010-09-02 18:43:28 UTC
Created attachment 28832 [details]
Proposed patch
Comment 3 Florian Mickler 2010-09-06 10:57:58 UTC
On Mon, 06 Sep 2010 06:30:38 -0400
Doug Nazar <nazard.lkml@gmail.com> wrote:

>   On 2010-09-06 1:50 AM, Florian Mickler wrote:
> >
> > Paul provided a patch at
> > https://bugzilla.kernel.org/attachment.cgi?id=28832 .
> >
> > Has he pinged you already about it? You are not subscribed to the bug
> > and I didn't see anything on the netdev mailinglist or lkml.
> >
> 
> Sorry, kinda ignored this one once David said it was being worked on. 
> I've been busy trying to track down why my wireless isn't working.
> 
> For the record, neither Paul's patch (095d05: softirq: adjust error 
> check) or Ben's (24cd80: 
> 3c59x: Remove incorrect locking; correct documented lock hierarchy) 
> which is sitting in the net-2.6 fix the issue. Tested atop 2bfc96a 
> (Linux 2.6.36-rc3)
> 
> It seems to be an init issue as it only happens once during boot and 
> doesn't impact functionality.
> 
> Doug
>
Comment 4 Rafael J. Wysocki 2010-09-13 18:03:17 UTC
Patch : https://bugzilla.kernel.org/attachment.cgi?id=28832
Handled-By : Paul E. McKenney <paulmck@linux.vnet.ibm.com>
Comment 5 Rafael J. Wysocki 2010-09-20 18:55:57 UTC
This appears to be a duplicate of bug 18492, which is now fixed.  Closing.

*** This bug has been marked as a duplicate of bug 18492 ***

Note You need to log in before you can comment on or make changes to this bug.