Bug 16971 - qla4xxx compile failure on 32-bit PowerPC: missing readq and writeq
qla4xxx compile failure on 32-bit PowerPC: missing readq and writeq
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Product: IO/Storage
Classification: Unclassified
Component: SCSI
All Linux
: P1 normal
Assigned To: linux-scsi@vger.kernel.org
:
Depends on:
Blocks: 16444
  Show dependency treegraph
 
Reported: 2010-08-24 19:07 UTC by Maciej Rutecki
Modified: 2010-12-08 16:22 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.36-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-08-24 19:07:44 UTC
Subject    : qla4xxx compile failure on 32-bit PowerPC: missing readq and writeq
Submitter  : Meelis Roos <mroos@linux.ee>
Date       : 2010-08-19 21:03
Message-ID : alpine.SOC.1.00.1008192359310.19654@math.ut.ee
References : http://marc.info/?l=linux-kernel&m=128225184900892&w=2

This entry is being used for tracking a regression from 2.6.35. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Florian Mickler 2010-08-30 13:46:07 UTC
On Mon, 30 Aug 2010 11:45:56 +0300 (EEST)
Meelis Roos <mroos@linux.ee> wrote:

> Still present in 2.6.36-rc3.
>
Comment 2 Anonymous Emailer 2010-08-30 15:02:11 UTC
Reply-To: ravi.anand@qlogic.com

We are looking into it and will provide an update asap.

Thanks
Ravi

----- Original Message -----
From: linux-scsi-owner@vger.kernel.org <linux-scsi-owner@vger.kernel.org>
To: linux-scsi@vger.kernel.org <linux-scsi@vger.kernel.org>
Sent: Mon Aug 30 06:46:17 2010
Subject: [Bug 16971] qla4xxx compile failure on 32-bit PowerPC: missing readq and writeq

https://bugzilla.kernel.org/show_bug.cgi?id=16971


Florian Mickler <florian@mickler.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |florian@mickler.org




--- Comment #1 from Florian Mickler <florian@mickler.org>  2010-08-30 13:46:07 ---
On Mon, 30 Aug 2010 11:45:56 +0300 (EEST)
Meelis Roos <mroos@linux.ee> wrote:

> Still present in 2.6.36-rc3.
>
Comment 3 Rafael J. Wysocki 2010-09-22 18:04:46 UTC
On Wednesday, September 22, 2010, Meelis Roos wrote:
> > > > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=16971
> > > > Subject		: qla4xxx compile failure on 32-bit PowerPC: missing readq and writeq
> > > > Submitter	: Meelis Roos <mroos@linux.ee>
> > > > Date		: 2010-08-19 21:03 (33 days old)
> > > 
> > > Still present. The maintainer of the driver has a patch that I have 
> > > tested, and for quite some time now, but it still does not appear in 
> > > mainline.
> > 
> > Do you have a pointer to the maintainer and the patch, so that we can
> > update the bugzilla entry and ping the maintainer? 
> 
> The patch was made by Vikas Chaudhary <vikas.chaudhary@qlogic.com> 
> (CC:d) and sent to me by private me-mail. I was first dubious about 
> possible endianness problem with qla4xxx private readq and writeq 
> implementation but he told they forcefully tested it on PPC64 and it 
> worked.
> 
> Last I heard from him on September 6th when he wrote he intended to push 
> the patch upstream together with other patches the same week.
Comment 4 Rafael J. Wysocki 2010-10-13 20:19:53 UTC
On Wednesday, October 13, 2010, Meelis Roos wrote:
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=16971
> > Subject		: qla4xxx compile failure on 32-bit PowerPC: missing readq and writeq
> > Submitter	: Meelis Roos <mroos@linux.ee>
> > Date		: 2010-08-19 21:03 (53 days old)
> > Message-ID	: <alpine.SOC.1.00.1008192359310.19654@math.ut.ee>
> 
> Still present.
Comment 5 Rafael J. Wysocki 2010-11-19 20:06:51 UTC
On Friday, November 19, 2010, Meelis Roos wrote:
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=16971
> > Subject		: qla4xxx compile failure on 32-bit PowerPC: missing readq and writeq
> > Submitter	: Meelis Roos <mroos@linux.ee>
> > Date		: 2010-08-19 21:03 (92 days old)
> > Message-ID	: <<alpine.SOC.1.00.1008192359310.19654@math.ut.ee>>
> > References	: http://marc.info/?l=linux-kernel&m=128225184900892&w=2
> 
> Still unfixed in mainline.
Comment 6 Rafael J. Wysocki 2010-12-05 21:52:20 UTC
On Sunday, December 05, 2010, Meelis Roos wrote:
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.35 and 2.6.36.  Please verify if it still should
> > be listed and let the tracking team know (either way).
> 
> Yes, still present in yesterdays git.
Comment 7 Vikas 2010-12-08 12:08:15 UTC
Please apply following patch from Ben Hutchings to fix this issue.

http://marc.info/?l=linux-scsi&m=128593600201958&w=2

Thanks,
Vikas.
Comment 8 Florian Mickler 2010-12-08 16:22:10 UTC
Patch: http://marc.info/?l=linux-scsi&m=128590267608876&w=2

Note You need to log in before you can comment on or make changes to this bug.