Bug 16921 - hda-intel: ioremap error
hda-intel: ioremap error
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: PCI
All Linux
: P1 normal
Assigned To: drivers_pci@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-24 15:12 UTC by Bill Reyolds
Modified: 2015-06-09 22:10 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.35.3
Tree: Mainline
Regression: No


Attachments

Description Bill Reyolds 2010-08-24 15:12:59 UTC
snd_hda_intel driver fails to initialize on 2.6.33.5 smp kernel using onboard sound device listed as :

VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller)


dmesg output:

WARNING: at drivers/pci/pci.c:105 pci_ioremap_bar+0x57/0x60()
Hardware name: MS-7253
Modules linked in: snd_hda_intel(+) snd_hda_codec snd_hwdep snd_seq_dummy snd_seq_oss(+) snd_seq_midi_event snd_seq snd_seq_device shpchp snd_pcm_oss snd_pcm snd_timer snd_mixer_oss snd soundcore serio_raw pcspkr i2c_viapro i2c_core snd_page_alloc via_rhine mii sg sr_mod pci_hotplug binfmt_misc cpufreq_ondemand cpufreq_conservative cpufreq_powersave powernow_k8 freq_table mperf ohci1394 sbp2 raw1394 ieee1394 fuse wacom ppdev parport_pc parport floppy k8temp evdev processor thermal button dm_mod ide_generic pata_via ata_generic ide_pci_generic ide_gd_mod ide_core pata_acpi sata_via libata sd_mod scsi_mod crc_t10dif ext4 jbd2 crc16 uhci_hcd ohci_hcd ehci_hcd hid_logitech usbhid hid usbcore ff_memless
Pid: 1179, comm: modprobe Not tainted 2.6.35.3-pclos1 #1
Call Trace:
 [<c0146842>] warn_slowpath_common+0x72/0xa0
 [<c02c4877>] ? pci_ioremap_bar+0x57/0x60
 [<c02c4877>] ? pci_ioremap_bar+0x57/0x60
 [<c0146892>] warn_slowpath_null+0x22/0x30
 [<c02c4877>] pci_ioremap_bar+0x57/0x60
 [<f8293a71>] azx_probe+0x3e4/0xb88 [snd_hda_intel]
 [<c025b09a>] ? sysfs_addrm_finish+0x1a/0xb0
 [<c044bbb9>] ? mutex_lock+0x19/0x40
 [<c025bd43>] ? sysfs_do_create_link+0xb3/0x1c0
 [<c01667b4>] ? __blocking_notifier_call_chain+0x54/0x70
 [<c02c6af3>] local_pci_probe+0x13/0x20
 [<c02c7a88>] pci_device_probe+0x68/0x90
 [<c0356afc>] driver_probe_device+0x8c/0x2b0
 [<c02c6c9c>] ? pci_match_device+0xbc/0xd0
 [<c0357021>] __driver_attach+0x81/0x90
 [<c0355d33>] bus_for_each_dev+0x53/0x80
 [<c03568de>] driver_attach+0x1e/0x20
 [<c0356fa0>] ? __driver_attach+0x0/0x90
 [<c03561e7>] bus_add_driver+0x1c7/0x320
 [<c02c79c0>] ? pci_device_remove+0x0/0x40
 [<c035716a>] driver_register+0x6a/0x120
 [<c02c7cc5>] __pci_register_driver+0x45/0xb0
 [<f806c017>] alsa_card_azx_init+0x17/0x19 [snd_hda_intel]
 [<c0101132>] do_one_initcall+0x32/0x1d0
 [<f806c000>] ? alsa_card_azx_init+0x0/0x19 [snd_hda_intel]
 [<c017b6db>] sys_init_module+0x9b/0x1e0
 [<c0204392>] ? sys_read+0x42/0x70
 [<c0103c5f>] sysenter_do_call+0x12/0x28
---[ end trace d8f960968a7fb426 ]---
hda-intel: ioremap error
HDA Intel 0000:80:01.0: PCI INT A disabled
Comment 1 Bill Reyolds 2010-08-24 15:15:27 UTC
Correct kernel version should be 2.6.35.3.
Comment 2 Bill Reyolds 2010-10-02 18:40:49 UTC
This is still present in the 2.6.35.7 kernel and I have no sound. 

Pid: 464, comm: modprobe Not tainted 2.6.35.7-pclos1 #1
Call Trace:
 [<c0134724>] warn_slowpath_common+0x6a/0x7f
 [<c0266239>] ? pci_ioremap_bar+0x2c/0x5b
 [<c013474d>] warn_slowpath_null+0x14/0x18
 [<c0266239>] pci_ioremap_bar+0x2c/0x5b
 [<f8f18fb4>] azx_probe+0x355/0x951 [snd_hda_intel]
 [<c01ff7b5>] ? sysfs_add_one+0x18/0xc6
 [<c0266424>] local_pci_probe+0x13/0x15
 [<c0266ffc>] pci_device_probe+0x48/0x6b
 [<c02dba58>] driver_probe_device+0x94/0x11c
 [<c02dbb21>] __driver_attach+0x41/0x59
 [<c02db201>] bus_for_each_dev+0x42/0x6c
 [<c02db90c>] driver_attach+0x19/0x1b
 [<c02dbae0>] ? __driver_attach+0x0/0x59
 [<c02db5da>] bus_add_driver+0x94/0x1c6
 [<c025256b>] ? kset_find_obj+0x23/0x4f
 [<c02dbd7b>] driver_register+0x7e/0xe5
 [<c039d4d7>] ? notifier_call_chain+0x2b/0x4d
 [<c02671d2>] __pci_register_driver+0x3d/0x9a
 [<c014d2a8>] ? __blocking_notifier_call_chain+0x45/0x51
 [<f8f1e000>] ? alsa_card_azx_init+0x0/0x19 [snd_hda_intel]
 [<f8f1e017>] alsa_card_azx_init+0x17/0x19 [snd_hda_intel]
 [<c0101154>] do_one_initcall+0x62/0x16b
 [<c015d4c7>] sys_init_module+0x7c/0x19d
 [<c01032df>] sysenter_do_call+0x12/0x28
---[ end trace 606907ed10fa95f1 ]---
hda-intel: ioremap error
HDA Intel 0000:80:01.0: PCI INT A disabled

Motherboard is a MSI K9-VGM-V

Vendor: ‎VIA Technologies, Inc.

VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE

‎VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller)

‎AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
Comment 3 Bill Reyolds 2010-12-10 02:48:58 UTC
Same bug with Kernel 2.6.36.1 NO SOUND

------------[ cut here ]------------
WARNING: at drivers/pci/pci.c:105 pci_ioremap_bar+0x57/0x60()
Hardware name: MS-7253
Modules linked in: snd_hda_intel(+) snd_hda_codec snd_hwdep snd_seq_dummy snd_seq_oss(+) snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_pcm wacom shpchp snd_timer ppdev via_rhine parport_pc evdev floppy i2c_viapro pci_hotplug snd_mixer_oss i2c_core mii button k8temp parport processor thermal sr_mod snd serio_raw sg soundcore snd_page_alloc ide_generic pata_via ata_generic ide_pci_generic ide_gd_mod ide_core pata_acpi sata_via libata sd_mod scsi_mod crc_t10dif ext4 jbd2 crc16 uhci_hcd ohci_hcd ehci_hcd hid_logitech usbhid hid usbcore ff_memless
Pid: 485, comm: modprobe Not tainted 2.6.36.1-pclos1 #1
Call Trace:
 [<c0147ed2>] warn_slowpath_common+0x72/0xa0
 [<c02cb4a7>] ? pci_ioremap_bar+0x57/0x60
 [<c02cb4a7>] ? pci_ioremap_bar+0x57/0x60
 [<c0147f22>] warn_slowpath_null+0x22/0x30
 [<c02cb4a7>] pci_ioremap_bar+0x57/0x60
 [<f8743b4d>] azx_probe+0x3e4/0xb88 [snd_hda_intel]
 [<c02629cd>] ? sysfs_add_one+0x1d/0x110
 [<c0364290>] ? __pm_runtime_set_status+0x150/0x1e0
 [<c0364368>] ? pm_runtime_enable+0x48/0x80
 [<c02cd9d7>] local_pci_probe+0x47/0xb0
 [<f8743769>] ? azx_probe+0x0/0xb88 [snd_hda_intel]
 [<c02ce7b8>] pci_device_probe+0x68/0x90
 [<c035d49c>] driver_probe_device+0x8c/0x2b0
 [<c02cd95c>] ? pci_match_device+0xbc/0xd0
 [<c035d9c1>] __driver_attach+0x81/0x90
 [<c035c703>] bus_for_each_dev+0x53/0x80
 [<c035d25e>] driver_attach+0x1e/0x20
 [<c035d940>] ? __driver_attach+0x0/0x90
 [<c035cb97>] bus_add_driver+0x1a7/0x2f0
 [<c02b1023>] ? kset_find_obj+0x33/0x60
 [<c02cec70>] ? pci_device_remove+0x0/0x100
 [<c035db0a>] driver_register+0x6a/0x120
 [<c02ce9f5>] __pci_register_driver+0x45/0xb0
 [<f8749017>] alsa_card_azx_init+0x17/0x19 [snd_hda_intel]
 [<c0101135>] do_one_initcall+0x35/0x170
 [<f8749000>] ? alsa_card_azx_init+0x0/0x19 [snd_hda_intel]
 [<c017e6ae>] sys_init_module+0x11e/0xc80
 [<c0208892>] ? rw_verify_area+0x62/0xd0
 [<c0103bdf>] sysenter_do_call+0x12/0x28
---[ end trace 9650703b58a901fe ]---
hda-intel: ioremap error
HDA Intel 0000:80:01.0: PCI INT A disabled
Comment 4 Bill Reyolds 2011-01-20 05:46:02 UTC
This bug is still present in kernel 2.6.37. NO SOUND!
 
WARNING: at drivers/pci/pci.c:118 pci_ioremap_bar+0x57/0x60()
Hardware name: MS-7253
Modules linked in: snd_hda_codec_hdmi snd_hda_intel(+) snd_hda_codec snd_seq_dummy snd_hwdep snd_seq_oss(+) snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_pcm snd_timer snd_mixer_oss snd ppdev soundcore shpchp parport_pc snd_page_alloc i2c_viapro pci_hotplug parport evdev i2c_core k8temp button sr_mod sg via_rhine mii ehci_hcd floppy processor uhci_hcd usbcore ide_generic pata_via ata_generic ide_pci_generic ide_gd_mod ide_core pata_acpi sata_via libata sd_mod scsi_mod crc_t10dif ext4 jbd2 crc16
Pid: 436, comm: modprobe Not tainted 2.6.37-pclos1 #1
Call Trace:
 [<c0143302>] warn_slowpath_common+0x72/0xa0
 [<c02c8ba7>] ? pci_ioremap_bar+0x57/0x60
 [<c02c8ba7>] ? pci_ioremap_bar+0x57/0x60
 [<c0143352>] warn_slowpath_null+0x22/0x30
 [<c02c8ba7>] pci_ioremap_bar+0x57/0x60
 [<f860576c>] azx_probe+0x3a3/0xa53 [snd_hda_intel]
 [<c025f6fd>] ? sysfs_add_one+0x1d/0x120
 [<c0361838>] ? __pm_runtime_set_status+0x148/0x1e0
 [<c03612f5>] ? pm_runtime_enable+0x45/0x70
 [<c02cb157>] local_pci_probe+0x47/0xb0
 [<f86053c9>] ? azx_probe+0x0/0xa53 [snd_hda_intel]
 [<c02cbee8>] pci_device_probe+0x68/0x90
 [<c035a333>] driver_probe_device+0x83/0x190
 [<c02cb0dc>] ? pci_match_device+0xbc/0xd0
 [<c035a741>] __driver_attach+0x81/0x90
 [<c0359723>] bus_for_each_dev+0x53/0x80
 [<c035a1ae>] driver_attach+0x1e/0x20
 [<c035a6c0>] ? __driver_attach+0x0/0x90
 [<c0359a9f>] bus_add_driver+0xcf/0x290
 [<c02cc3a0>] ? pci_device_remove+0x0/0x100
 [<c035a88a>] driver_register+0x6a/0x120
 [<c02cc125>] __pci_register_driver+0x45/0xb0
 [<f860a017>] alsa_card_azx_init+0x17/0x19 [snd_hda_intel]
 [<c0101135>] do_one_initcall+0x35/0x170
 [<f860a000>] ? alsa_card_azx_init+0x0/0x19 [snd_hda_intel]
 [<c017978e>] sys_init_module+0x11e/0xc60
 [<c020463a>] ? rw_verify_area+0x6a/0x120
 [<c0103d1f>] sysenter_do_call+0x12/0x28
---[ end trace 2c47cd73da2fa9e4 ]---
hda-intel: ioremap error
HDA Intel 0000:80:01.0: PCI INT A disable
Comment 5 Bill Reyolds 2011-01-20 10:11:07 UTC
Finally got sound using pci=use_crs on the grub boot line. Don't know what the hell this does but at least sound works and no kernel oops at boot.
Comment 6 Bjorn Helgaas 2015-06-09 20:24:26 UTC
Reopening because "pci=use_crs" is a workaround but not a fix.

If you still have this hardware, please attach a complete dmesg log (booted without "pci=use_crs").  We should be able to do something in the kernel so the "pci=use_crs" is not needed.
Comment 7 Bjorn Helgaas 2015-06-09 22:10:33 UTC
Should be fixed by these commits, which appeared in v3.3:

  http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=841137170961
  http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=a97f4f5e524b

Closing again, please reopen if you still see this problem

Note You need to log in before you can comment on or make changes to this bug.