Bug 1688 - blank screen after resume from S3
Summary: blank screen after resume from S3
Status: REJECTED DUPLICATE of bug 3670
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Luming Yu
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-12-16 08:19 UTC by Stefan Armbruster
Modified: 2005-01-03 19:51 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.0-test11
Tree: Mainline
Regression: ---


Attachments
output of acpidmp (52.45 KB, text/plain)
2003-12-16 08:22 UTC, Stefan Armbruster
Details
output of dmesg -s40000 (11.89 KB, text/plain)
2003-12-16 08:22 UTC, Stefan Armbruster
Details
output of dmidecode (13.95 KB, text/plain)
2003-12-16 08:23 UTC, Stefan Armbruster
Details
output of /proc/interrupts, lspci and lsmod (10.48 KB, text/plain)
2003-12-16 08:25 UTC, Stefan Armbruster
Details

Description Stefan Armbruster 2003-12-16 08:19:41 UTC
Distribution: Suse 9.0
Hardware Environment: Dell Inspiron 8500
Software Environment: Kernel 2.6.0test11 + acpi patch
acpi-20031203-2.6.0-test11.diff.bz2
Problem Description:
echo -n mem > /sys/power/state
brings the notebook down as expected. After pressing the power button, it
resumes but the screen is blank. Keyboard works but there's nothing visible on
the screen. There's no X running, only text mode.


Steps to reproduce:
see above
Comment 1 Stefan Armbruster 2003-12-16 08:22:14 UTC
Created attachment 1683 [details]
output of acpidmp
Comment 2 Stefan Armbruster 2003-12-16 08:22:53 UTC
Created attachment 1684 [details]
output of dmesg -s40000
Comment 3 Stefan Armbruster 2003-12-16 08:23:21 UTC
Created attachment 1685 [details]
output of dmidecode
Comment 4 Stefan Armbruster 2003-12-16 08:25:06 UTC
Created attachment 1686 [details]
output of /proc/interrupts, lspci and lsmod
Comment 5 Luming Yu 2003-12-16 19:21:25 UTC
It sounds like video driver issue. Maybe you need to contract video driver writer.
Comment 6 Georg Greve 2004-01-24 02:29:15 UTC
Possibly related to

http://bugzilla.kernel.org/show_bug.cgi?id=1877 ?
Comment 7 Venkatesh Pallipadi 2004-11-03 18:32:19 UTC
Is the problem still there with latest 2.6 kernel?

If yes, can you make sure whether the problem is only with restore of the 
video (try connecting through network or serial after resume).

If it is only the video problem, 
- Please try the options in Documentation/power/video.txt
- Try the workaround in bug #3670
Comment 8 Len Brown 2005-01-03 19:51:11 UTC

*** This bug has been marked as a duplicate of 3670 ***

Note You need to log in before you can comment on or make changes to this bug.