Bug 16771 - [Bisected Regression in 2.6.35] A full tmpfs filesystem causes hibernationto hang
[Bisected Regression in 2.6.35] A full tmpfs filesystem causes hibernationto ...
Status: CLOSED CODE_FIX
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 7216 16055
  Show dependency treegraph
 
Reported: 2010-08-21 20:05 UTC by Maciej Rutecki
Modified: 2010-09-20 19:18 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.35
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-08-21 20:05:42 UTC
Subject    : [Bisected Regression in 2.6.35] A full tmpfs filesystem causes hibernationto hang
Submitter  : "M. Vefa Bicakci" <bicave@superonline.com>
Date       : 2010-08-15 5:25
Message-ID : 4C677A49.4030904@superonline.com
References : http://marc.info/?l=linux-kernel&m=128184995401968&w=2

This entry is being used for tracking a regression from 2.6.34. Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit bb21c7ce18eff8e6e7877ca1d06c6db719376e3c
Author: KOSAKI Motohiro <kosaki.motohiro@jp.fujitsu.com>
Date:   Fri Jun 4 14:15:05 2010 -0700

    vmscan: fix do_try_to_free_pages() return value when priority==0 reclaim failure

First-Bad-Commit : bb21c7ce18eff8e6e7877ca1d06c6db719376e3c
Comment 1 Florian Mickler 2010-09-06 07:27:15 UTC
Proposed Patch: https://patchwork.kernel.org/patch/155431/
Comment 2 Rafael J. Wysocki 2010-09-20 19:18:46 UTC
Fixed by commit 6715045ddc7472a22be5e49d4047d2d89b391f45 .

Note You need to log in before you can comment on or make changes to this bug.