Bug 16681 - touchpad is recognized as generic mouse
touchpad is recognized as generic mouse
Status: RESOLVED DUPLICATE of bug 14660
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 high
Assigned To: drivers_input-devices
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-21 07:27 UTC by Ivan Baidakou
Modified: 2010-09-22 23:02 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.35
Tree: Mainline
Regression: No


Attachments
dmesg output (73.32 KB, text/plain)
2010-09-22 02:12 UTC, Josh Smith
Details
dmesg output (15.32 KB, text/plain)
2010-09-22 17:59 UTC, Ivan Baidakou
Details
full dmesg output (68.64 KB, text/plain)
2010-09-22 20:45 UTC, Ivan Baidakou
Details

Description Ivan Baidakou 2010-08-21 07:27:20 UTC
My touchpad is recognized as PS/2 mouse, not as Synaptics device, as it should. 

The same problem is described here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/565543

cat /proc/bus/input/devices 

I: Bus=0011 Vendor=0002 Product=0005 Version=0000
N: Name="ImPS/2 Generic Wheel Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input1
U: Uniq=
H: Handlers=mouse0 event1 
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=103


# grep -i synaptics .config
CONFIG_MOUSE_PS2_SYNAPTICS=y
# CONFIG_MOUSE_SYNAPTICS_I2C is not set

Thanks!
Comment 1 Dmitry Torokhov 2010-08-23 16:08:13 UTC
Is the touchpad really Synaptics and not ALPS, Elantech, FSP and so forth? What driver does the other OS uses for it? Also, was tere a kernel that detected the touchpad properly or was it always broken?
Comment 2 Josh Smith 2010-09-22 02:06:46 UTC
I have the same issue. 
Running Ubuntu 10.10 
Kernel 2.6.35-22-generic

cat /proc/bus/input/devices output

I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name="PS/2 Generic Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input11
U: Uniq=
H: Handlers=mouse0 event11 
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=3

Output from tpconfig

Found Synaptics Touchpad.
Firmware: 8.96 (multiple-byte mode).

dmesg output attached
Comment 3 Josh Smith 2010-09-22 02:11:24 UTC
Additionally:

Touchpad has not worked under any of the following kernels.

2.6.35-20-generic
2.6.32-25-generic
2.6.32-21-generic
Comment 4 Josh Smith 2010-09-22 02:12:29 UTC
Created attachment 30942 [details]
dmesg output

Output of dmesg to help identify the cause of the problem.
Comment 5 Dmitry Torokhov 2010-09-22 16:40:37 UTC
(In reply to comment #2)
> Output from tpconfig
> 
> Found Synaptics Touchpad.
> Firmware: 8.96 (multiple-byte mode).
> 
> dmesg output attached

If I see another tpconfig output I am gonna scream... The utility does not work.

Please boot with "i8042.debug" on the kernel command line and provide full dmesg. Thanks.
Comment 6 Ivan Baidakou 2010-09-22 17:59:59 UTC
Created attachment 31022 [details]
dmesg output

dmesg output with i8042.debug option
Comment 7 Dmitry Torokhov 2010-09-22 18:20:23 UTC
_Full_ dmesg, please. I need to see the device initialization phase, not only you working your touchpad/typing. Probably if you boot into text console you will be able to capture more? Also try adding log_buf_len=131072 to the kernel command line.

Thanks.
Comment 8 Ivan Baidakou 2010-09-22 20:45:34 UTC
Created attachment 31052 [details]
full dmesg output
Comment 9 Dmitry Torokhov 2010-09-22 23:02:00 UTC
OK, it's another 73 02 64 model touchpad.

*** This bug has been marked as a duplicate of bug 14660 ***

Note You need to log in before you can comment on or make changes to this bug.