Bug 16639 - All blocks of an older NAND device reported bad
All blocks of an older NAND device reported bad
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Flash/Memory Technology Devices
All Linux
: P1 normal
Assigned To: David Woodhouse
:
Depends on:
Blocks: 16444
  Show dependency treegraph
 
Reported: 2010-08-20 19:30 UTC by Janusz Krzysztofik
Modified: 2010-08-24 21:05 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.36-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Janusz Krzysztofik 2010-08-20 19:30:47 UTC
Latest changes to drivers/mtd/nand/nand-{base,bbt}.c break support for the following device found on my ARM OMAP based Amstrad Delta videophone:

NAND device: Manufacturer ID: 0x98, Chip ID: 0x75 (Toshiba NAND 32MiB 3,3V 8-bit)

All blocks are detected bad, resulting in the device being not usable at all.

The problem has been introduced with the following commit:
mtd: nand: refactor BB marker detection
c7b28e25cb9beb943aead770ff14551b55fa8c79

Reverting it, plus two more that depend on it, corrects the problem for me.

Since I'm new to NAND, please give me a hint how I could try to correct it other than reverting the commits, which I assume may be required by other, new devices.

Thanks,
Janusz
Comment 1 David Woodhouse 2010-08-20 19:48:23 UTC
http://git.infradead.org/mtd-2.6.git/commitdiff/065a1ed8 ?
Comment 2 Janusz Krzysztofik 2010-08-20 21:15:26 UTC
Yes, this patch corrects the problem for me, thanks. And sorry for not checking your repository before reporting.

Thanks,
Janusz
Comment 3 David Woodhouse 2010-08-20 21:40:06 UTC
I think I have to come clean and admit that although the gitweb interface says it was committed 31 hours ago, I actually forgot to *push* it until just before I made comment #1 :)

Thanks for the confirmation -- this will go to Linus in the next day or so. I think I have everything I need to submit in the tree now.
Comment 4 Rafael J. Wysocki 2010-08-24 21:05:00 UTC
Fixed by commit 065a1ed8de85583888b3d4f22c64b534a1fbdaaa .

Note You need to log in before you can comment on or make changes to this bug.