Bug 16632 - general protection fault: 0000 [#1] PREEMPT SMP
general protection fault: 0000 [#1] PREEMPT SMP
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
All Linux
: P1 normal
Assigned To: platform_i386
:
Depends on:
Blocks: 16444
  Show dependency treegraph
 
Reported: 2010-08-19 19:27 UTC by Maciej Rutecki
Modified: 2010-08-29 22:14 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.36-rc0
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-08-19 19:27:23 UTC
Subject    : general protection fault: 0000 [#1] PREEMPT SMP
Submitter  : Sergey Senozhatsky <sergey.senozhatsky@gmail.com>
Date       : 2010-08-13 13:47
Message-ID : 20100813134756.GA5235@swordfish.minsk.epam.com
References : http://marc.info/?l=linux-kernel&m=128170730427818&w=2

This entry is being used for tracking a regression from 2.6.35. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Dan Carpenter 2010-08-23 19:46:24 UTC
Tejun touched this code last.  :P

The commit 3a101d0548e9 "sched: adjust when cpu_active and cpuset configurations are updated during cpu on/offlining" changes stuff in _cpu_down().  If code got scheduled on an offline cpu that would cause a GPF I think.
    
I added him to the CC list.
Comment 2 Tejun Heo 2010-08-24 08:59:30 UTC
Following up via mail.  Thanks.
Comment 3 Dan Carpenter 2010-08-24 11:52:18 UTC
It was unrelated to Tejun's patch.  Sorry I doubted you Tejun...  :P

Fixed by:  602586a83b719 "shmem: put_super must percpu_counter_destroy"

http://marc.info/?l=linux-kernel&m=128264148332228&w=2

Note You need to log in before you can comment on or make changes to this bug.