Bug 1661 - SCI interrupt lost after resuming from S3
SCI interrupt lost after resuming from S3
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake
i386 Linux
: P2 normal
Assigned To: Robert Moore
:
: 1801 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-09 04:07 UTC by Luming Yu
Modified: 2004-06-09 23:57 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6
Tree: Mainline
Regression: ---


Attachments
a patch for fixing this issue (1.27 KB, patch)
2003-12-09 04:12 UTC, Luming Yu
Details | Diff

Description Luming Yu 2003-12-09 04:07:37 UTC
SCI interrupt alwasy lost after resuming from S3 on T21.
After resuming from S3, if you press power button, nothing happend.
Comment 1 Luming Yu 2003-12-09 04:12:20 UTC
Created attachment 1641 [details]
a patch for fixing this issue

There are two points including in this patch:
1. After waking up, we need to clear status register of GPE block.
2. After waking up, we need to clear power button status register, and set
power button enable register.
Comment 2 Luming Yu 2003-12-09 04:13:28 UTC
This patch fix SCI lost issue on my T21. I hope it will fix your issue too.
Comment 3 Brian Perkins 2003-12-09 09:11:33 UTC
Issue fixed on my Thinkpad R32.  Thanks!
Comment 4 Ari Pollak 2003-12-17 16:48:28 UTC
so is there a bug tracking when this will be merged?
Comment 5 Ari Pollak 2003-12-17 16:49:21 UTC
oops, nevermind.
Comment 6 Michal Schmidt 2003-12-18 01:48:27 UTC
The patch fixes the issue on my ThinkPad R40.
Comment 7 Luming Yu 2004-01-06 17:01:38 UTC
*** Bug 1801 has been marked as a duplicate of this bug. ***
Comment 8 Ari Pollak 2004-01-06 18:21:39 UTC
This patch doesn't seem to have helped on my Thinkpad T41.
Comment 9 Wilfried Klaebe 2004-01-27 11:35:23 UTC
This patch also doesnt help me on my ThinkPad R40
Comment 10 Rolf Offermanns 2004-01-31 19:07:10 UTC
Patch works for me:
IBM Thinkpad R40 2681CDG.
Comment 11 Ari Pollak 2004-02-04 19:27:19 UTC
*** Bug 1801 has been marked as a duplicate of this bug. ***
Comment 12 Len Brown 2004-02-04 19:29:22 UTC
Bob, 
Luming's ACPICA patch appears to be effective -- assigning this one to you. 
 
thanks, 
-Len 
 
Comment 13 Robert Moore 2004-02-12 16:26:28 UTC
Should we maybe clear/enable ALL fixed events on wake?  This may preemptively 
solve some problems.

Bob
Comment 14 Tim Nordell 2004-02-13 17:02:28 UTC
>Should we maybe clear/enable ALL fixed events on wake?  This may preemptively 
>solve some problems.

Out of curiousity - I tried this out on my T41 - as this patch does not fix the
interrupt lost problem on it.  Does not help.  :(  (If I did it right that is. 
I did a for loop for the possible static events, instead of just doing
ACPI_EVENT_POWER_BUTTON).  I posted this in bug 1415 as well, but I applied that
patch, so I could try out having the lid resume my machine.  It works when the
ACPI interrupts are being received - but after that(so the first time it works),
it immediately resumes the kernel instead of actually going to sleep - as if it
got the lid event again to resume.  If I turn off the lid event from that patch
- it will sleep, but obviously, the lid won't wake it up again.
Comment 15 Robert Moore 2004-02-20 15:13:01 UTC
Both fixes integrated into 20040220
Comment 16 Shaohua 2004-06-09 23:57:55 UTC
If luming's patch can't help you, please try the patch in Bug 2643, it 
resolved similar issue in my T40.

Note You need to log in before you can comment on or make changes to this bug.