Bug 16590 - System never resumes from suspend
System never resumes from suspend
Status: CLOSED UNREPRODUCIBLE
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 high
Assigned To: power-management_other
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2010-08-14 13:05 UTC by bjwest
Modified: 2011-07-30 06:24 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.32-34
Tree: Mainline
Regression: No


Attachments

Description bjwest 2010-08-14 13:05:01 UTC
I recently bought an Acer Aspire 7552G-5107.  I originally installed Kubuntu Maverick with the 2.6.35 kernel on which the suspend to RAM/Disk did not work.  I've since moved back to lenny with the 2.6.32 kernel due to official ATI driver incompatibilities with the new kernel, and (not unexpectedly) suspend also does not work.

Kubuntu Power Management shows suspend to disk and suspend to RAM as supported as well as DPMS and ConsoleKit Runtime Support and states there are no issues found with my configuration.

When I resume from a suspended system, I get a blank screen.  There is no disk activity, and I have to cycle power to boot normally.

I am more than willing to help with this, but I have no idea where to start.  What info do you need, and how do I get it?  I've already updated the BIOS to the latest on Acers site.
Comment 1 Rafael J. Wysocki 2010-08-16 18:50:36 UTC
Have you tried with vga=0 in the kernel command line and no X?
Comment 2 bjwest 2010-08-17 09:56:29 UTC
(In reply to comment #1)
> Have you tried with vga=0 in the kernel command line and no X?

I just tried that with the same results.  The power light comes on, no disk activity (although the dvd does cycle, possibly just a poweron thing) and a blank screen.

I found and followed some debugging tips at https://wiki.ubuntu.com/DebuggingKernelSuspend, but I don't get anything that looks remotely similar to what they say I should in the log file.

That site also led me to http://ubuntuforums.org/showthread.php?p=3066404.  It's three years old, but I'll read through it and see if I can get any more info.  Although with no disk activity trying to resume, I doubt there will be any type of info in the logs to help.
(In reply to comment #1)
> Have you tried with vga=0 in the kernel command line and no X?
Comment 3 Rafael J. Wysocki 2010-09-23 23:24:13 UTC
You can try the following test:

# echo core > /sys/power/pm_test
# echo mem > /sys/power/state

and see if it gets back to the command prompt (it should do that after about 5-10 seconds, depending on how much it takes to resume devices on your machine).
Comment 4 bjwest 2010-12-06 11:55:39 UTC
(In reply to comment #3)
> You can try the following test:
> 
> # echo core > /sys/power/pm_test
> # echo mem > /sys/power/state
> 
> and see if it gets back to the command prompt (it should do that after about
> 5-10 seconds, depending on how much it takes to resume devices on your
> machine).

Never returns.  Screen goes blank with blinking cursor in upper-left corner.  Left it for about 5 min. or so before I cycled power to reboot.
Comment 5 bjwest 2011-05-25 18:07:25 UTC
Seems to be fixed in Kubuntu 11.04 with kernel 2.6.38.

I'm changing this to Resolved, CODE_FIX.  If that's not the correct status, let me know what it should be.

Note You need to log in before you can comment on or make changes to this bug.