Bug 16587 - System hangs on s2ram
System hangs on s2ram
Status: CLOSED INSUFFICIENT_DATA
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 high
Assigned To: power-management_other
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2010-08-14 11:03 UTC by Ivan Baidakou
Modified: 2012-05-24 07:38 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.35
Tree: Mainline
Regression: No


Attachments

Description Ivan Baidakou 2010-08-14 11:03:18 UTC
When I boon in minimalisting environment (single user mode, without Xorg etc.) and try to s2ram it hangs on "Snapshotting system state". Suspending led is blinking and system is unresponsible. 

my boot params are:
root=/dev/sda4 resume=swap:/dev/sda1 acpi_sleep=s3_bios nomodeset

My laptop is eMachines D440-1202G16Mi, with AMD V120 processor onboard. I can provide additional information (lspci, lshw) if it is requered.
Comment 1 Rafael J. Wysocki 2010-08-16 18:48:26 UTC
First, please try with acpi_sleep=nonvs in the kernel command line.
Comment 2 Ivan Baidakou 2010-08-16 19:04:39 UTC
(In reply to comment #1)

The same result (failure) for s2disk. (There was an mistake in my previous post : it failed for s2disk, for s2ram it says:
Machine is unknown.
This machine can be identified by:
    sys_vendor   = "eMachines      "
    sys_product  = "eMachines D440                 "
    sys_version  = "V1.04          "
    bios_version = "V1.04          "
See http://suspend.sf.net/s2ram-support.html for details.

If you report a problem, please include the complete output above.
)
Comment 3 Rafael J. Wysocki 2010-09-23 23:27:13 UTC
Please try the following test:

# echo devices > /sys/power/pm_test
# echo disk > /sys/power/state

and see if it gets back to the command prompt (it should do that after about 5-10 seconds, depending on how much it takes to resume devices on your machine).
Comment 4 Ivan Baidakou 2010-09-24 09:44:24 UTC
Thanks, but there is no /sys/power/pm_test

ls -lah /sys/power/
total 0
drwxr-xr-x  2 root root    0 Sep 24 12:38 .
drwxr-xr-x 12 root root    0 Sep 24  2010 ..
-rw-r--r--  1 root root 4.0K Sep 24 12:38 disk
-rw-r--r--  1 root root 4.0K Sep 24 12:39 image_size
-rw-r--r--  1 root root 4.0K Sep 24 12:39 pm_async
-rw-r--r--  1 root root 4.0K Sep 24 12:39 resume
-rw-r--r--  1 root root 4.0K Sep 24 12:38 state

I simply tried to do "echo disk > /sys/power/state" and it hanged as usual.

I don't know, whether the following be useful: I reported other bug, that my touchpad is recognized as generic PS/2 mouse, and I found the touchpad driver uses some new protocol... and it's developing in process, but some people aslo noted hibernate problems (https://bugzilla.kernel.org/show_bug.cgi?id=14660). 

I uncheked all mise in device drivers, recompiled-rebooted... but it hangs again.

What can I do else?
Comment 5 Rafael J. Wysocki 2010-09-24 19:54:28 UTC
Please build the kernel with CONFIG_PM_DEBUG set and carry out the test from comment #3.
Comment 6 Ivan Baidakou 2010-09-24 20:42:26 UTC
I have done it. It resumes after a few seconds. Do you need dmesg output after resume? What is the next?
Comment 7 Ivan Baidakou 2010-10-28 18:55:17 UTC
What additional info can I provide?
Comment 8 Zhang Rui 2012-01-18 02:17:06 UTC
It's great that kernel bugzilla is back.

can you please verify if the problem still exists in the latest upstream
kernel?
Comment 9 Zhang Rui 2012-05-24 07:38:12 UTC
bug closed as there is no response from the bug reporter.
please feel free to reopen it if the problem still exists in the latest upstream kernel.

Note You need to log in before you can comment on or make changes to this bug.