Bug 16544 - drivers/power/olpc_battery.c:387: error: unknown field ‘owner’ specified in initializer
drivers/power/olpc_battery.c:387: error: unknown field ‘owner’ specified in i...
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Other
All Linux
: P1 blocking
Assigned To: Guenter Roeck
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-08 22:07 UTC by jd1008
Modified: 2010-08-11 03:02 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.35-git6
Tree: Mainline
Regression: No


Attachments
kernel configuration file (91.82 KB, application/octet-stream)
2010-08-08 22:07 UTC, jd1008
Details

Description jd1008 2010-08-08 22:07:19 UTC
Created attachment 27380 [details]
kernel configuration file

Tried to build 2.6.35-git6 
Errors stopped the build.

.
.
.
  CC      drivers/power/power_supply_leds.o
  CC      drivers/power/olpc_battery.o
  CC      net/wireless/wext-priv.o
  CC [M]  net/sunrpc/auth_gss/gss_krb5_keys.o
drivers/power/olpc_battery.c:387: error: unknown field ‘owner’ specified in initializer
drivers/power/olpc_battery.c:387: warning: excess elements in struct initializer
drivers/power/olpc_battery.c:387: warning: (near initialization for ‘olpc_bat_eeprom.attr’)
make[2]: *** [drivers/power/olpc_battery.o] Error 1
make[1]: *** [drivers/power] Error 2
make[1]: *** Waiting for unfinished jobs....

.config attached
Comment 1 jd1008 2010-08-09 01:36:03 UTC
Same error in 2.6.35-git7:
.....
  CC      drivers/power/olpc_battery.o
  CC [M]  drivers/net/e1000e/ethtool.o
drivers/power/olpc_battery.c:387: error: unknown field ‘owner’ specified in initializer
drivers/power/olpc_battery.c:387: warning: excess elements in struct initializer
drivers/power/olpc_battery.c:387: warning: (near initialization for ‘olpc_bat_eeprom.attr’)
  CC [M]  drivers/net/enic/enic_res.o
make[2]: *** [drivers/power/olpc_battery.o] Error 1

used same config file as above.
Comment 2 jd1008 2010-08-09 01:52:37 UTC
Ditto in git8:

  CC      drivers/power/olpc_battery.o
drivers/power/olpc_battery.c:387: error: unknown field ‘owner’ specified in initializer
drivers/power/olpc_battery.c:387: warning: excess elements in struct initializer
drivers/power/olpc_battery.c:387: warning: (near initialization for ‘olpc_bat_eeprom.attr’)
make[1]: *** [drivers/power/olpc_battery.o] Error 1
make: *** [drivers/power/olpc_battery.o] Error 2
Comment 3 jd1008 2010-08-09 06:58:56 UTC
Folks, I am wondering why someone deleted

struct module           *owner;

from  struct attribute in file
include/linux/sysfs.h

This is what is breaking the compilation.

If it was removed for good reason, then why was the reference to it also not removed?
Comment 4 Guenter Roeck 2010-08-10 15:24:18 UTC
The field was deleted because it is no longer used. As for why I didn't catch this one - sorry, I am only human.
Comment 5 Guenter Roeck 2010-08-10 15:25:12 UTC
Patch submitted.
Comment 6 Guenter Roeck 2010-08-11 03:00:46 UTC
Patch integrated. Someone with permissions might want to close this bug.

Note You need to log in before you can comment on or make changes to this bug.