Bug 16514 - Blank laptop panel after loading i915
Summary: Blank laptop panel after loading i915
Status: CLOSED DUPLICATE of bug 16496
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-dri-intel@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks: 16055
  Show dependency tree
 
Reported: 2010-08-04 12:24 UTC by byron
Modified: 2010-08-29 22:43 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.34.2, 2.6.35
Tree: Mainline
Regression: Yes


Attachments

Description byron 2010-08-04 12:24:11 UTC
Hardware - Dell Latitude E6410
Video Card -
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
        Subsystem: Dell Device 040a
        Flags: bus master, fast devsel, latency 0, IRQ 28
        Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 70b0 [size=8]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Capabilities: [a4] PCI Advanced Features
        Kernel driver in use: i915
        Kernel modules: i915

Kernel Versions That Work: 2.6.34, 2.6.34.1
Kernel Versions That Do Not Work: 2.6.34.2, 2.6.35

Problem: Blank screen after loading i915 module.

After loading the i915 module from one of the affected kernels, the laptop display panel is blank, but backlit.  After starting X, "xrandr --output DP1 --off; xrandr --output DP1 --auto" turns the backlight off and then on again, but the display remains blank.

Booting the laptop in a docking station with an external monitor attached shows the display on the external monitor.
Comment 1 byron 2010-08-04 19:45:39 UTC
A quick bisect points to this patch as the source of trouble:

commit b8c63c5fbc0e8d124f9e15cbbb0585b762efa08d
Author: Jesse Barnes <jbarnes@virtuousgeek.org>
Date:   Mon Jul 26 13:51:22 2010 -0700

    drm/i915: make sure we shut off the panel in eDP configs
    
    commit 5620ae29f1eabe655f44335231b580a78c8364ea upstream.
    
    Fix error from the last pull request.  Making sure we shut the panel off
    is more correct and saves power.
    
    Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>
    Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
    Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>

:040000 040000 92b89828b32273d2ffc0e27adb697078178baff1 8138149cd70f9bb5dc11c61c0c648a2f477a67f3 M      drivers

Unfortunately, I did get it to work once, even with this commit, so I'm not sure how accurate the bisect is.
Comment 2 byron 2010-08-04 20:57:50 UTC
Confirmed, after dropping b8c63c5fbc0e8d124f9e15cbbb0585b762efa08d from 2.6.34.2, the laptop display works on every boot.
Comment 3 Rafael J. Wysocki 2010-08-04 22:58:30 UTC
First-Bad-Commit : b8c63c5fbc0e8d124f9e15cbbb0585b762efa08d
Comment 4 Gordon Jin 2010-08-05 01:26:59 UTC
Let's track at https://bugs.freedesktop.org/show_bug.cgi?id=29278

*** This bug has been marked as a duplicate of bug 16496 ***

Note You need to log in before you can comment on or make changes to this bug.