Bug 16505 - 2.6.34.2 breaks b43
2.6.34.2 breaks b43
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 normal
Assigned To: drivers_network-wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks: 16055
  Show dependency treegraph
 
Reported: 2010-08-03 23:53 UTC by archman
Modified: 2010-08-30 17:41 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.34.2
Tree: Mainline
Regression: Yes


Attachments
Fix for BCM43XX problems in 2.6.34.2 (687 bytes, patch)
2010-08-04 02:56 UTC, Larry Finger
Details | Diff

Description archman 2010-08-03 23:53:27 UTC
After upgrading to ARCH 2.6.34.2-1 it is no longer possible to use the broadcom wireless cards BCM4311, BCM4312, BCM4318 and possibly some others (also refering to the official kernel log: http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.34.2
Line:
"ssb: Handle Netbook devices where the SPROM address is changed. For some Netbook computers with Broadcom BCM4312 wireless interfaces,the SPROM has been moved to a new location. When the ssb driver tries to read the old location, the systems hangs when trying to read a non-existent location. Such freezes are particularly bad as they do not log the failure."

When trying to ifconfig wlan0 up, I get: "SCIOCSIFFLAGS: Cannot assign requested address' while trying 'ifconfig wlan0 up". Downgrading to 2.6.34.1-1 solves the problem, though.

08:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)

Further info and discussion here, please: https://bbs.archlinux.org/viewtopic.php?id=102212
Comment 1 archman 2010-08-03 23:54:22 UTC
Also, is the new 2.6.35 affected by this in any way?
Comment 2 Larry Finger 2010-08-04 02:56:49 UTC
Created attachment 27335 [details]
Fix for BCM43XX problems in 2.6.34.2

This problem is my fault. The offset calculated for the SPROM is wrong as shown in the attached patch. The commit 4584740e4ec1db166d862112b1b90e35cadaad03 has been a problem, but I did not think it was in 2.6.34.2 as GregKH reported a merge problem with it.

v2.6.35 is not affected by this problem. It will cause a problem for some Netbook computers with BCM4312 cards as they will freeze when loading ssb. That fix will be in 2.6.35.

Sorry for the problem.
Comment 3 archman 2010-08-04 08:01:31 UTC
Thank you, Larry. Cheers! :)
Comment 4 KoS 2010-08-04 08:25:33 UTC
I also had this problem with a Broadcom BCM4312 but moving to kernel 2.6.35
solved the issue.
Comment 5 Rafael J. Wysocki 2010-08-04 09:43:58 UTC
Handled-By : Larry Finger <Larry.Finger@lwfinger.net>
Patch : https://bugzilla.kernel.org/attachment.cgi?id=27335
Comment 6 Biru Ionut 2010-08-04 21:31:55 UTC
i believe that 2.6.32.17 is affected too since it has the same ssb changes
Comment 7 Rafael J. Wysocki 2010-08-30 17:35:19 UTC
On Monday, August 30, 2010, Larry Finger wrote:
> On 08/29/2010 06:13 PM, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.34 and 2.6.35.
> > 
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.34 and 2.6.35.  Please verify if it still should
> > be listed and let the tracking team know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=16505
> > Subject		: 2.6.34.2 breaks b43
> > Submitter	: archman <spermmail001@yahoo.com>
> > Date		: 2010-08-03 23:53 (27 days old)
> > Handled-By	: Larry Finger <Larry.Finger@lwfinger.net>
> > Patch		: https://bugzilla.kernel.org/attachment.cgi?id=27335
> 
> This one was fixed in 2.6.34.3. Mainline was OK - only the patches to stable
> were affected. The bug should be closed.

Note You need to log in before you can comment on or make changes to this bug.