Bug 16501 - 2.6.35 suspend regression (bisected)
2.6.35 suspend regression (bisected)
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 high
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
: 16524 (view as bug list)
Depends on:
Blocks: 7216 16055
  Show dependency treegraph
 
Reported: 2010-08-03 19:19 UTC by Maciej Rutecki
Modified: 2010-08-24 20:07 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.35
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-08-03 19:19:48 UTC
Subject    : 2.6.35 suspend regression (bisected)
Submitter  : Roberto Oppedisano <roberto.oppedisano@infracom.it>
Date       : 2010-07-25 20:27
Message-ID : 4C4C9E40.7070209@infracom.it
References : http://marc.info/?l=linux-kernel&m=128009001003625&w=2

This entry is being used for tracking a regression from 2.6.34. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Roberto Oppedisano 2010-08-04 08:03:44 UTC
I've found that this issue is the same described in:

http://marc.info/?t=128065346900002&r=1&w=2

The proposed workaround of setting

#define HAS_BSD(dev)            (0)

in i915_drv.h works also for me.
Comment 2 Gordon Jin 2010-08-09 06:56:18 UTC
*** Bug 16524 has been marked as a duplicate of this bug. ***
Comment 3 Gordon Jin 2010-08-09 06:57:32 UTC
also tracked at https://bugs.freedesktop.org/show_bug.cgi?id=29406
Comment 4 Thomas Meyer 2010-08-24 17:32:08 UTC
Seems to be fixed in 2.6.36-rc2. Probably by merge commit 
4238a417a91643e1162a98770288f630e37f0484
Comment 5 Rafael J. Wysocki 2010-08-24 20:07:01 UTC
Closing, please reopen if you see it again.

Note You need to log in before you can comment on or make changes to this bug.