Bug 16500 - "quiet" mount option is ignored for *fat file systems, allow_utime appears on its own [Fedora? bug]
Summary: "quiet" mount option is ignored for *fat file systems, allow_utime appears on...
Status: CLOSED INVALID
Alias: None
Product: File System
Classification: Unclassified
Component: FAT/VFAT/MSDOS (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: OGAWA Hirofumi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-03 15:22 UTC by Artem S. Tashkinov
Modified: 2013-03-07 02:38 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.35
Tree: Mainline
Regression: Yes


Attachments

Description Artem S. Tashkinov 2010-08-03 15:22:04 UTC
Steps to reproduce:

1) mv /etc/fstab /etc/fstab.save
2) mount -o quiet /dev/sdaX /mnt/fat32
3) 

/proc/mounts: vfat rw,relatime,fmask=0022,dmask=0022,codepage=cp866,iocharset=utf8,shortname=mixed,errors=remount-ro

so "quiet" option is being ignored.

Another problem is that sometimes a new option appears which I don't have anywhere in my fstab:

allow_utime=0020
Comment 1 OGAWA Hirofumi 2010-08-03 23:24:21 UTC
# mount -t vfat -o quiet,loop file m
# cat /proc/mounts | grep loop
/dev/loop0 /tmp/m vfat rw,relatime,fmask=0022,dmask=0022,codeage=cp437,iocharset=iso8859-1,shortname=mixed,quiet,errors=remount-ro 0 0

I couldn't reproduce "quiet" problem (tested 2.6.35-rc5).

And

Yes, allow_utime is setted from dmask by default. So, it appers.

Thanks
Comment 2 Artem S. Tashkinov 2010-08-04 08:27:40 UTC
2.6.35 final.

# mkfs.vfat -v testfile
mkfs.vfat 3.0.9 (31 Jan 2010)
Auto-selecting FAT32 for large filesystem
ext2.img has 64 heads and 32 sectors per track,
logical sector size is 512,
using 0xf8 media descriptor, with 1228800 sectors;
file system has 2 32-bit FATs and 8 sectors per cluster.
FAT size is 1200 sectors, and provides 153296 clusters.
There are 32 reserved sectors.
Volume ID is 39e47cc9, no volume label.

# mount -o quiet,loop testfile loop
# cat /proc/mounts | grep loop

/dev/loop0 /tmp/loop vfat rw,relatime,fmask=0022,dmask=0022,codepage=cp866,iocharset=utf8,shortname=mixed,errors=remount-ro 0 0

No "quiet" again.
Comment 3 Artem S. Tashkinov 2010-08-04 09:36:18 UTC
I can reproduce it in Fedora 13 with all updates installed, but other people cannot reproduce it with e.g. Gentoo, so I have no idea why and where this mount option is lost.

mount version seems not to be responsible for this bug.

The fact is that on the same PC kernel 2.6.34 doesn't exhibit this problem.
Comment 4 Artem S. Tashkinov 2010-08-04 09:55:30 UTC
strace shows this call: mount("/dev/loop0", "loop", "vfat", MS_MGC_VAL|MS_SILENT, NULL) = 0, that means mount command works correctly.

So there can be only two culprits: either kernel or glibc.

I have glibc-2.12-3.i686 here.
Comment 5 Artem S. Tashkinov 2010-08-04 13:38:20 UTC
People have reproduced this problem with 2.6.34 kernel on Fedora 13.

It seems like glibc is playing some dirty tricks here.
Comment 6 OGAWA Hirofumi 2010-08-04 14:00:19 UTC
Probably, it would be problem of mount command.

MS_SILENT isn't right one in here. It should be

  mount("/dev/loop0", "m", "vfat", MS_MGC_VAL, "quiet") = 0

i.e. "quiet" option should be passed as is, not MS_SILENT.
Comment 7 Artem S. Tashkinov 2010-08-07 07:52:21 UTC
I suppose you are right, thus I'm closing this bug as INVALID.

Fedora bug report is filed here: https://bugzilla.redhat.com/show_bug.cgi?id=622089

Note You need to log in before you can comment on or make changes to this bug.