Bug 16496 - Black screen on Dell E6510
Summary: Black screen on Dell E6510
Status: CLOSED INVALID
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-dri-intel@kernel-bugs.osdl.org
URL:
Keywords:
: 16514 (view as bug list)
Depends on:
Blocks: 16055
  Show dependency tree
 
Reported: 2010-08-02 22:13 UTC by henk
Modified: 2010-08-05 14:25 UTC (History)
7 users (show)

See Also:
Kernel Version: 2.6.35
Tree: Mainline
Regression: Yes


Attachments

Description henk 2010-08-02 22:13:28 UTC
On my Dell E6510 I get a black screen as soon as the i915 KMS module is loaded.
Kernel 2.6.23-rc6 did not have this problem.

After some investigation, I found out that this patch introduced the problem:

diff --git a/drivers/gpu/drm/i915/intel_dp.c b/drivers/gpu/drm/i915/intel_dp.c
index 5d42661..5dde80f 100644 (file)
--- a/drivers/gpu/drm/i915/intel_dp.c
+++ b/drivers/gpu/drm/i915/intel_dp.c
@@ -798,7 +798,7 @@ intel_dp_dpms(struct drm_encoder *encoder, int mode)
                        intel_dp_link_down(intel_encoder, dp_priv->DP);
                        if (IS_eDP(intel_encoder)) {
                                ironlake_edp_backlight_off(dev);
-                               ironlake_edp_backlight_off(dev);
+                               ironlake_edp_panel_off(dev);
                        }
                }
        } else {
Comment 1 Andrew Morton 2010-08-02 22:18:10 UTC
I assume 2.6.23-rc6 was a typo.

I marked it as a regression.

Jesse, you broke henk's computer :)
Comment 2 Jesse Barnes 2010-08-02 22:38:08 UTC
Sigh.  Fix one 6510, break another.  I've really got to get one of these machines...
Comment 3 henk 2010-08-02 22:49:46 UTC
This machine gives me some headaches too. If you want me to test some patches or if you need more information, please let me know.
Comment 4 Jesse Barnes 2010-08-03 18:39:19 UTC
Dupe of https://bugs.freedesktop.org/show_bug.cgi?id=29278

*** This bug has been marked as a duplicate of bug 1 ***
Comment 5 Gordon Jin 2010-08-05 01:27:00 UTC
*** Bug 16514 has been marked as a duplicate of this bug. ***
Comment 6 Brice Goglin 2010-08-05 14:25:59 UTC
Reverting the aforementioned commit also helps on my Dell latitude E6410 (Core i7 620M with integrated graphics controller [8086:0046]). I
didn't have any problem like this one with all kernels I previously tried (up to
2.6.35-rc4). Today, I switched to drm-core-next to get VGA to work (see
https://bugs.freedesktop.org/show_bug.cgi?id=29005), got the aforementioned
blank screen, and fixed it by reverting the above patch.

Note You need to log in before you can comment on or make changes to this bug.