Bug 16458 - Bluetooth disabled after resume
Bluetooth disabled after resume
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Bluetooth
All Linux
: P1 normal
Assigned To: drivers_bluetooth@kernel-bugs.osdl.org
:
Depends on:
Blocks: 7216 16055
  Show dependency treegraph
 
Reported: 2010-07-25 09:33 UTC by AttilaN
Modified: 2011-01-17 22:21 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.35
Tree: Mainline
Regression: Yes


Attachments
Error message during resume (2.81 KB, text/plain)
2010-07-25 09:33 UTC, AttilaN
Details

Description AttilaN 2010-07-25 09:33:22 UTC
Created attachment 27244 [details]
Error message during resume

If I suspend my laptop while the bluetooth mouse is connected, I get the attached error ("sysfs: cannot create duplicate filename") during resume and bluetooth is disabled.
Tested on ubuntu maverick kernels (2.6.35-*) and mainline rc6, same results. It worked fine on 2.6.34 and 32.

this is what I see when the mouse is not connected:
ls -l /sys/class/bluetooth/
lrwxrwxrwx 1 root root 0 2010-07-25 10:31 hci0 -> ../../devices/pci0000:00/0000:00:1d.3/usb5/5-2/5-2.1/5-2.1:1.0/bluetooth/hci0

after connecting:
ls -l /sys/class/bluetooth/
lrwxrwxrwx 1 root root 0 2010-07-25 10:37 hci0 -> ../../devices/pci0000:00/0000:00:1d.3/usb5/5-2/5-2.1/5-2.1:1.0/bluetooth/hci0
lrwxrwxrwx 1 root root 0 2010-07-25 10:39 hci0:11 -> ../../devices/pci0000:00/0000:00:1d.3/usb5/5-2/5-2.1/5-2.1:1.0/bluetooth/hci0/hci0:11

On resume from standby, the hci0:11 entry is gone on 2.6.32 and 34 kernels but remains there using 2.6.35 (seems like that's causing the error?)
Comment 1 Florian Mickler 2010-09-08 12:09:42 UTC
On Mon, 2 Aug 2010 14:19:59 +0200
Oliver Neukum <oliver@neukum.org> wrote:

> 
> Which power state is that? S1, S3 or S4?
> 
> 	Regards
> 		Oliver
Comment 2 AttilaN 2010-09-08 15:51:24 UTC
suspend (not hibernate), would that be S3?
/apps/gnome-power-manager/buttons/lid_ac=suspend
Comment 3 Rafael J. Wysocki 2010-09-20 19:21:57 UTC
On Sunday, September 19, 2010, Attila Nagy wrote:
> hi,
> I've tested now with 2.6.35.4 and 2.6.36-rc4 from the ubuntu mainline PPA.
> with 35 I got the same results as in the bug report, with 36 resume doesn't
> work at all (LEDs are on, screen off, only hard reset helps)
Comment 4 Rafael J. Wysocki 2011-01-16 22:36:14 UTC
Is the problem still present in 2.6.37?
Comment 5 AttilaN 2011-01-17 09:41:21 UTC
Installed v2.6.37-natty from mainline PPA - the issue is gone. There are no warnings on the console after resume from standby and the bluetooth mouse works fine. Thx!
Comment 6 Rafael J. Wysocki 2011-01-17 22:21:45 UTC
Cool, thanks!

Note You need to log in before you can comment on or make changes to this bug.