Bug 16448 - 2.6.35-rc5 panic at __br_deliver+0x64/0xe0 with kvm bridge networking
Summary: 2.6.35-rc5 panic at __br_deliver+0x64/0xe0 with kvm bridge networking
Status: CLOSED CODE_FIX
Alias: None
Product: Networking
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Herbert Xu
URL:
Keywords:
Depends on:
Blocks: 16055
  Show dependency tree
 
Reported: 2010-07-23 17:24 UTC by Maciej Rutecki
Modified: 2010-09-12 18:55 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.35-rc5
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-07-23 17:24:58 UTC
Subject    : 2.6.35-rc5 panic at __br_deliver+0x64/0xe0 with kvm bridge networking
Submitter  : caiqian@redhat.com
Date       : 2010-07-23 3:25
Message-ID : 198123598.1050221279855515402.JavaMail.root@zmail06.collab.prod.int.phx2.redhat.com
References : http://marc.info/?l=linux-kernel&m=127985553916052&w=2

This entry is being used for tracking a regression from 2.6.34. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Herbert Xu 2010-07-26 06:04:28 UTC
You need to either disable netpoll, or upgrade to the latest 2.6.35 kernel which disables netpoll on bridges.

2.6.36 will have working support for bridge netpoll.
Comment 2 Chuck Ebbert 2010-08-19 06:54:51 UTC
Fixed by 573201f36fd9c7c6d5218cdcd9948cee700b277d ("bridge: Partially disable netpoll support") in 2.6.35-rc6.

I can't close bugs, so someone else will have to do that.

Note You need to log in before you can comment on or make changes to this bug.