Bug 16435 - ath5k (AR5001) does not work after resume and fails with "ath5k phy0: gain calibration timeout"
Summary: ath5k (AR5001) does not work after resume and fails with "ath5k phy0: gain ca...
Status: RESOLVED DUPLICATE of bug 16436
Alias: None
Product: Networking
Classification: Unclassified
Component: Wireless (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: networking_wireless@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-22 01:34 UTC by boris64
Modified: 2010-07-22 02:05 UTC (History)
0 users

See Also:
Kernel Version: 2.6.34.1
Tree: Mainline
Regression: No


Attachments
lspci -vv (21.82 KB, text/plain)
2010-07-22 01:34 UTC, boris64
Details

Description boris64 2010-07-22 01:34:53 UTC
Created attachment 27195 [details]
lspci -vv

On my Asus-F5N notebook the ath5k module works really fine
together with the built-in Atheros AR5001 wireless adapter.
Well, until i set this laptop into suspend mode (via pm-suspend).
After resume my syslog gets spammed with messages like
"kernel: ath5k phy0: gain calibration timeout (2427MHz)".
Whatever i do next (unload+load ath5k or even reboot), i'll _never_
be able to get a working wlan connection again. If i do a
'iwlist wlan0 scan' no network shows up (aka 'no scan results').

There is just one way to get a working wlan adapter again:
1) Power-off
2) Power-on
3) Wlan via ath5k works again (until pm-suspend of course)

Please tell me what logs etc. you need to debug/fix this issue.

PS: I already tried the latest compat-wireless stuff with the very same result.
On WindowsXP the wireless adapter works as expected after suspend/resume,
so i think this can't be just some kind of hardware/firmware error.
FYI this also happens with madwifi (module ath_pci).
Comment 1 boris64 2010-07-22 02:01:49 UTC
This bug is a duplicate of https://bugzilla.kernel.org/show_bug.cgi?id=16436.
Somehow the bugzilla.kernel.org website timed out while saving this report.
Comment 2 boris64 2010-07-22 02:05:52 UTC

*** This bug has been marked as a duplicate of bug 16436 ***

Note You need to log in before you can comment on or make changes to this bug.