Bug 16406 - Badness with the kernel version 2.6.35-rc1-git1 running on P6 box
Summary: Badness with the kernel version 2.6.35-rc1-git1 running on P6 box
Status: CLOSED CODE_FIX
Alias: None
Product: Memory Management
Classification: Unclassified
Component: Slab Allocator (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Andrew Morton
URL:
Keywords:
Depends on:
Blocks: 16055
  Show dependency tree
 
Reported: 2010-07-17 05:51 UTC by Maciej Rutecki
Modified: 2010-09-08 11:25 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.35-rc5-git1
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-07-17 05:51:51 UTC
Subject    : Badness with the kernel version 2.6.35-rc1-git1 running on P6 box
Submitter  : divya <dipraksh@linux.vnet.ibm.com>
Date       : 2010-07-16 8:50
Message-ID : 4C401D56.3070108@linux.vnet.ibm.com
References : http://marc.info/?l=linux-kernel&m=127927024906085&w=2

This entry is being used for tracking a regression from 2.6.34.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Florian Mickler 2010-09-08 11:25:10 UTC
Patch for this issue is merged mainline in 2.6.36-rc1.

commit 3d8009c780ee90fccb5c171caf30aff839f13547
Author: Brian King <brking@linux.vnet.ibm.com>
Date:   Wed Jun 30 11:59:12 2010 +0000

    ehea: Allocate stats buffer with GFP_KERNEL
    
    Since ehea_get_stats calls ehea_h_query_ehea_port, which
    can sleep, we can also sleep when allocating a page in
    this function. This fixes some memory allocation failure
    warnings seen under low memory conditions.
    
    Signed-off-by: Brian King <brking@linux.vnet.ibm.com>
    Signed-off-by: David S. Miller <davem@davemloft.net>



If this issue still exists, please shout.

Note You need to log in before you can comment on or make changes to this bug.