Bug 16401 - 2.6.35-r5 ext3 corruptions
Summary: 2.6.35-r5 ext3 corruptions
Status: CLOSED INVALID
Alias: None
Product: File System
Classification: Unclassified
Component: ext3 (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: fs_ext3@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks: 16055
  Show dependency tree
 
Reported: 2010-07-15 17:44 UTC by Maciej Rutecki
Modified: 2010-07-20 15:18 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.35-rc5
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-07-15 17:44:12 UTC
Subject    : 2.6.35-r5 ext3 corruptions
Submitter  : Dave Chinner <david@fromorbit.com>
Date       : 2010-07-15 10:57
Message-ID : 20100715105745.GI30737@dastard
References : http://marc.info/?l=linux-kernel&m=127919148825845&w=2

This entry is being used for tracking a regression from 2.6.34.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Dave Chinner 2010-07-19 23:41:54 UTC
The problem appears to have been specific to a single filesystem that was corrupted in some way that e2fsck did not detect. e2fsck would report the fs as clean (even with a forced check) but the problem would come back, always on inodes around the 211,000 number.

The filesystem eventually trashed itself, but I made a fat-fingered mistake and backed up the wrong image whenthe problem first manifested. Hence I can't reproduce the problem now because I had to re-image the root drive.

From this, I'd say this is not a regression, so closing this bug is fine by me...
Comment 2 Rafael J. Wysocki 2010-07-20 15:18:06 UTC
Closing, then.

Note You need to log in before you can comment on or make changes to this bug.