Bug 16399 - perf failed with kernel 2.6.35-rc
perf failed with kernel 2.6.35-rc
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
All Linux
: P1 normal
Assigned To: platform_i386
:
Depends on:
Blocks: 16055
  Show dependency treegraph
 
Reported: 2010-07-15 17:29 UTC by Maciej Rutecki
Modified: 2010-08-30 17:06 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.35-rc
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-07-15 17:29:30 UTC
Subject    : perf failed with kernel 2.6.35-rc
Submitter  : "Zhang, Yanmin" <yanmin_zhang@linux.intel.com>
Date       : 2010-07-13 8:14
Message-ID : 1279008849.2096.913.camel@ymzhang.sh.intel.com
References : http://marc.info/?l=linux-kernel&m=127900880212470&w=2

This entry is being used for tracking a regression from 2.6.34.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 1ac62cfff252fb668405ef3398a1fa7f4a0d6d15
Author: Peter Zijlstra <peterz@infradead.org>
Date:   Fri Mar 26 14:08:44 2010 +0100

    perf, x86: Add Nehelem PMU programming errata workaround

First-Bad-Commit : 1ac62cfff252fb668405ef3398a1fa7f4a0d6d15
Comment 1 Chuck Ebbert 2010-08-19 07:28:59 UTC
There is no commit 1ac62cfff252fb668405ef3398a1fa7f4a0d6d15, the correct commit is 11164cd.

A fix is queued for this and needs to go into 2.6.35 as well:
http://git.kernel.org/tip/351af0725e5222e35741011d1ea62215c1ed06db
Comment 2 Florian Mickler 2010-08-30 13:55:01 UTC
Fixed by: 

commit 351af0725e5222e35741011d1ea62215c1ed06db
Author: Zhang, Yanmin <yanmin_zhang@linux.intel.com>
Date:   Fri Aug 6 13:39:08 2010 +0800

    perf, x86: Fix Intel-nhm PMU programming errata workaround

Note You need to log in before you can comment on or make changes to this bug.