Bug 16377 - X.org crash while running a OpenGL composited KDE 4.4.4 session with Radeon KMS
X.org crash while running a OpenGL composited KDE 4.4.4 session with Radeon KMS
Status: RESOLVED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks: 15310
  Show dependency treegraph
 
Reported: 2010-07-13 12:41 UTC by Martin Steigerwald
Modified: 2010-12-07 21:21 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.34
Tree: Mainline
Regression: Yes


Attachments
huge snippet of syslog with a complete backtrace of the X.org crash (56.71 KB, application/x-bzip)
2010-07-13 12:41 UTC, Martin Steigerwald
Details

Description Martin Steigerwald 2010-07-13 12:41:25 UTC
Created attachment 27086 [details]
huge snippet of syslog with a complete backtrace of the X.org crash

Affected kernel versions:
- 2.6.34.1-tp42-toi-3.1.1.1-04990-g3a7d1f4

Last kernel that worked:
- 2.6.33.2-tp42-toi-3.1-lowmem-free-991-992-04964-gf00c7ec-dirty (including
some patches to explicitely allow freeing lowmem pages on hibernation - I
tested them for Nigel)
- possibly also 2.6.34-tp42-toi-3.1-04981-gb9a071a, I didn't have the X.org crash there, but it I didn't use two X.org sessions with that kernel AFAIR or at least not for long.

While searching for stuff in the logs for bug #16376, I found the following backtraces in syslog. These were prior to the freeze reported in bug #16376. I remember that yesterday the second X.org KDE session just crashed two times dropping me back to the KDM login.

Jul 12 16:48:37 shambhala kernel: Pid: 16124, comm: Xorg Not tainted 2.6.34.1-tp42-toi-3.1.1.1-04990-g3a7d1f4 #3 2373
CXG/2373CXG
Jul 12 16:48:37 shambhala kernel: EIP: 0060:[<f850699c>] EFLAGS: 00013246 CPU: 0
Jul 12 16:48:37 shambhala kernel: EIP is at ttm_bo_unreserve+0xbc/0xd0 [ttm]
Jul 12 16:48:37 shambhala kernel: EAX: 00000000 EBX: ee4eb62c ECX: f63183f4 EDX: 00000000
Jul 12 16:48:37 shambhala kernel: ESI: 00000000 EDI: ee4eb654 EBP: ef82fc0c ESP: ef82fbfc
Jul 12 16:48:37 shambhala kernel: DS: 007b ES: 007b FS: 0000 GS: 00e0 SS: 0068
Jul 12 16:48:37 shambhala kernel: Process Xorg (pid: 16124, ti=ef82e000 task=f625cb00 task.ti=ef82e000)
Jul 12 16:48:37 shambhala kernel: Stack:
Jul 12 16:48:37 shambhala kernel: f8a7aeb0 ee4eb62c 00000000 ee4eb654 ef82fc90 f850721d 00000001 00000000
Jul 12 16:48:37 shambhala kernel: <0> c10f8f00 00100100 00200200 da539190 e41a9600 00000001 01000000 f6a013a4
Jul 12 16:48:37 shambhala kernel: <0> f63184e0 f63184e0 f63183f4 00000000 00000001 00000000 00000000 00000001
Jul 12 16:48:37 shambhala kernel: Call Trace:
Jul 12 16:48:37 shambhala kernel: [<f8a7aeb0>] ? radeon_bo_move_notify+0x0/0x30 [radeon]
Jul 12 16:48:37 shambhala kernel: [<f850721d>] ? ttm_mem_evict_first+0x1dd/0x500 [ttm]
Jul 12 16:48:37 shambhala kernel: [<c10f8f00>] ? pollwake+0x0/0x60
Jul 12 16:48:37 shambhala kernel: [<f85078ff>] ? ttm_bo_mem_space+0x3bf/0x4c0 [ttm]
Jul 12 16:48:37 shambhala kernel: [<f8507a96>] ? ttm_bo_move_buffer+0x96/0x120 [ttm]
Jul 12 16:48:37 shambhala kernel: [<f84bf579>] ? drm_mm_kmalloc+0x29/0x190 [drm]
Jul 12 16:48:37 shambhala kernel: [<f8507bac>] ? ttm_bo_validate+0x8c/0x120 [ttm]
Jul 12 16:48:37 shambhala kernel: [<f8507e8e>] ? ttm_bo_init+0x24e/0x2f0 [ttm]
Jul 12 16:48:37 shambhala kernel: [<f8a7b6a9>] ? radeon_bo_create+0xe9/0x210 [radeon]
Jul 12 16:48:37 shambhala kernel: [<f8a7b470>] ? radeon_ttm_bo_destroy+0x0/0xa0 [radeon]
Jul 12 16:48:37 shambhala kernel: [<f8a8ef06>] ? radeon_gem_object_create+0x76/0xe0 [radeon]
Jul 12 16:48:37 shambhala kernel: [<f8a8efd3>] ? radeon_gem_create_ioctl+0x63/0xe0 [radeon]
Jul 12 16:48:37 shambhala kernel: [<f84b61d6>] ? drm_ioctl+0x186/0x410 [drm]
Jul 12 16:48:37 shambhala kernel: [<f8a8ef70>] ? radeon_gem_create_ioctl+0x0/0xe0 [radeon]
Jul 12 16:48:37 shambhala kernel: [<f8a79adc>] ? radeon_ttm_fault+0x1c/0x30 [radeon]
Jul 12 16:48:37 shambhala kernel: [<c10cdeb0>] ? __do_fault+0x40/0x460
Jul 12 16:48:37 shambhala kernel: [<c10f7002>] ? vfs_ioctl+0x32/0xb0
Jul 12 16:48:37 shambhala kernel: [<f84b6050>] ? drm_ioctl+0x0/0x410 [drm]
Jul 12 16:48:37 shambhala kernel: [<c10f7802>] ? do_vfs_ioctl+0x72/0x5d0
Jul 12 16:48:37 shambhala kernel: [<c1021db6>] ? do_page_fault+0x1b6/0x3d0
Jul 12 16:48:37 shambhala kernel: [<c10e98bf>] ? vfs_read+0x11f/0x190
Jul 12 16:48:37 shambhala kernel: [<c10f7d9e>] ? sys_ioctl+0x3e/0x60
Jul 12 16:48:37 shambhala kernel: [<c1002f23>] ? sysenter_do_call+0x12/0x2c
Jul 12 16:48:37 shambhala kernel: Code: 43 2c 31 c9 ba 03 00 00 00 c7 04 24 00 00 00 00 e8 ca 8a b2 c8 89 e0 25 00 e0
 ff ff ff 48 14 f6 40 08 08 75 0a 5a 5b 5e 5f 5d c3 <0f> 0b eb fe e8 fb ec ef c8 eb ef 0f 0b eb fe 90 8d 74 26 00 55 
Jul 12 16:48:37 shambhala kernel: EIP: [<f850699c>] ttm_bo_unreserve+0xbc/0xd0 [ttm] SS:ESP 0068:ef82fbfc
Jul 12 16:48:37 shambhala kernel: ---[ end trace 8d691734d7b6abed ]---
Jul 12 16:48:37 shambhala kernel: note: Xorg[16124] exited with preempt_count 1
Jul 12 16:48:37 shambhala kernel: BUG: scheduling while atomic: Xorg/16124/0x10000002
Jul 12 16:48:37 shambhala kernel: Modules linked in: snd_usb_audio snd_hwdep snd_usb_lib sata_sil vboxnetadp vboxnetflt vboxdrv acpi_cpufreq cpufreq_userspace cpufreq_stats cpufreq_conservative cpufreq_powersave ipv6 ppdev lp microcode fuse tun usblp ohci_hcd usb_storage usb_libusual nls_iso8859_15 nls_iso8859_1 nls_cp850 ntfs vfat msdos fat reiserfs isofs udf crc_itu_t smbfs pktcdvd uinput radeon ttm drm_kms_helper drm i2c_algo_bit hdaps tp_smapi thinkpad_ec dm_crypt snd_intel8x0 snd_intel8x0m snd_ac97_codec ac97_bus snd_pcm_oss snd_mireq cpufreq_userspace cpufreq_stats cpufreq_conservative cpufreq_powersave ipv6 ppdev lp microcode fuse tun usblp ohci_hcd usb_storage usb_libusual nls_iso8859_15 nls_iso8859_1 nls_cp850 ntfs vfat msdos fat reiserfs isofs udf crc_itu_t smbfs pktcdvd uinput radeon ttm drm_kms_helper drm i2c_algo_bit hdaps tp_smapi thinkpad_ec dm_crypt snd_intel8x0 snd_intel8x0m snd_ac97_codec ac97_bus snd_pcm_oss snd_mixer_oss thinkpad_acpi hwmon snd_pcm snd_seq_dummy pcmcia snd_seq_oss snd_seq_midi s
Jul 12 16:48:37 shambhala kernel: nd_rawmidi snd_seq_midi_event snd_seq intel_agp yenta_socket rsrc_nonstatic parport_pc agpgart snd_timer joydev pcmcia_core parport ipw2200 libipw rtc_cmos snd_seq_device cfg80211 snd rfkill lib80211 led_class nvram rtc_core rtc_lib i2c_i801 evdev ac battery video output processor snd_page_alloc button dm_mod raid10 raid456 async_pq async_xor xor async_memcpy async_raid6_recov raid6_pq async_tx raid1 raid0 linear md_mod btrfs zlib_deflate crc32c libcrc32c usbhid uhci_hcd sg sr_mod cdrom thermal ehci_hcd usbcore [last unloaded: scsi_wait_scan]
Jul 12 16:48:37 shambhala kernel: Pid: 16124, comm: Xorg Tainted: G      D    2.6.34.1-tp42-toi-3.1.1.1-04990-g3a7d1f4 #3
Jul 12 16:48:37 shambhala kernel: Call Trace:
Jul 12 16:48:37 shambhala kernel: [<c1029cf1>] __schedule_bug+0x61/0x70
Jul 12 16:48:37 shambhala kernel: [<c140549d>] schedule+0x3ed/0x4d0
Jul 12 16:48:37 shambhala kernel: [<c140593e>] _cond_resched+0x2e/0x50
Jul 12 16:48:37 shambhala kernel: [<c10cdd37>] unmap_vmas+0x597/0x5b0
Jul 12 16:48:37 shambhala kernel: [<c100682e>] ? mask_and_ack_8259A+0xde/0x100
Jul 12 16:48:37 shambhala kernel: [<c10d4963>] exit_mmap+0x93/0x170
Jul 12 16:48:37 shambhala kernel: [<c103288b>] mmput+0x3b/0xe0
Jul 12 16:48:37 shambhala kernel: [<c1036dd3>] exit_mm+0xd3/0xf0
Jul 12 16:48:37 shambhala kernel: [<c1037ac5>] do_exit+0x5c5/0x710
Jul 12 16:48:37 shambhala kernel: [<c1006008>] oops_end+0x68/0xa0
Jul 12 16:48:37 shambhala kernel: [<c10061d4>] die+0x54/0x80
Jul 12 16:48:37 shambhala kernel: [<c1003656>] do_trap+0x96/0xd0
Jul 12 16:48:37 shambhala kernel: [<c1003a80>] ? do_invalid_op+0x0/0xb0
Jul 12 16:48:37 shambhala kernel: [<c1003b0c>] do_invalid_op+0x8c/0xb0
Jul 12 16:48:37 shambhala kernel: [<f850699c>] ? ttm_bo_unreserve+0xbc/0xd0 [ttm]
Jul 12 16:48:37 shambhala kernel: [<f8a9b9d0>] ? r100_copy_blit+0x0/0x660 [radeon]
Jul 12 16:48:37 shambhala kernel: [<f8a7a4a8>] ? radeon_bo_move+0x98/0x310 [radeon]
Jul 12 16:48:37 shambhala kernel: [<c1407d5f>] error_code+0x6b/0x70
Jul 12 16:48:37 shambhala kernel: [<f850699c>] ? ttm_bo_unreserve+0xbc/0xd0 [ttm]
Jul 12 16:48:37 shambhala kernel: [<f8a7aeb0>] ? radeon_bo_move_notify+0x0/0x30 [radeon]
Jul 12 16:48:37 shambhala kernel: [<f850721d>] ttm_mem_evict_first+0x1dd/0x500 [ttm]
Jul 12 16:48:37 shambhala kernel: [<c10f8f00>] ? pollwake+0x0/0x60
Jul 12 16:48:37 shambhala kernel: [<f85078ff>] ttm_bo_mem_space+0x3bf/0x4c0 [ttm]
Jul 12 16:48:37 shambhala kernel: [<f8507a96>] ttm_bo_move_buffer+0x96/0x120 [ttm]
Jul 12 16:48:37 shambhala kernel: [<f84bf579>] ? drm_mm_kmalloc+0x29/0x190 [drm]
Jul 12 16:48:37 shambhala kernel: [<f8507bac>] ttm_bo_validate+0x8c/0x120 [ttm]
Jul 12 16:48:37 shambhala kernel: [<f8507e8e>] ttm_bo_init+0x24e/0x2f0 [ttm]
Jul 12 16:48:37 shambhala kernel: [<f8a7b6a9>] radeon_bo_create+0xe9/0x210 [radeon]
Jul 12 16:48:37 shambhala kernel: [<f8a7b470>] ? radeon_ttm_bo_destroy+0x0/0xa0 [radeon]
Jul 12 16:48:37 shambhala kernel: [<f8a8ef06>] radeon_gem_object_create+0x76/0xe0 [radeon]
Jul 12 16:48:37 shambhala kernel: [<f8a8efd3>] radeon_gem_create_ioctl+0x63/0xe0 [radeon]
Jul 12 16:48:37 shambhala kernel: [<f84b61d6>] drm_ioctl+0x186/0x410 [drm]
Jul 12 16:48:37 shambhala kernel: [<f8a8ef70>] ? radeon_gem_create_ioctl+0x0/0xe0 [radeon]
Jul 12 16:48:37 shambhala kernel: [<f8a79adc>] ? radeon_ttm_fault+0x1c/0x30 [radeon]
Jul 12 16:48:37 shambhala kernel: [<c10cdeb0>] ? __do_fault+0x40/0x460
Jul 12 16:48:37 shambhala kernel: [<c10f7002>] vfs_ioctl+0x32/0xb0
Jul 12 16:48:37 shambhala kernel: [<f84b6050>] ? drm_ioctl+0x0/0x410 [drm]
Jul 12 16:48:37 shambhala kernel: [<c10f7802>] do_vfs_ioctl+0x72/0x5d0
Jul 12 16:48:37 shambhala kernel: [<c1021db6>] ? do_page_fault+0x1b6/0x3d0
Jul 12 16:48:37 shambhala kernel: [<c10e98bf>] ? vfs_read+0x11f/0x190
Jul 12 16:48:37 shambhala kernel: [<c10f7d9e>] sys_ioctl+0x3e/0x60
Jul 12 16:48:37 shambhala kernel: [<c1002f23>] sysenter_do_call+0x12/0x2c
Jul 12 16:48:37 shambhala kernel: BUG: scheduling while atomic: Xorg/16124/0x10000002
Jul 12 16:48:37 shambhala kernel: Modules linked in: snd_usb_audio snd_hwdep snd_usb_lib sata_sil vboxnetadp vboxnetflt vboxdrv acpi_cpufreq cpufreq_userspace cpufreq_stats cpufreq_conservative cpufreq_powersave ipv6 ppdev lp microcode fuse tun usblp ohci_hcd usb_storage usb_libusual nls_iso8859_15 nls_iso8859_1 nls_cp850 ntfs vfat msdos fat reiserfs isofs udf crc_itu_t smbfs pktcdvd uinput radeon ttm drm_kms_helper drm i2c_algo_bit hdaps tp_smapi thinkpad_ec dm_crypt snd_intel8x0 snd_intel8x0m snd_ac97_codec ac97_bus snd_pcm_oss snd_mixer_oss thinkpad_acpi hwmon snd_pcm snd_seq_dummy pcmcia snd_seq_oss snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq intel_agp yenta_socket rsrc_nonstatic parport_pc agpgart snd_timer joydev pcmcia_core parport ipw2200 libipw rtc_cmos snd_seq_device cfg80211 snd rfkill lib80211 led_class nvram rtc_core rtc_lib i2c_i801 evdev ac battery video output processor snd_page_alloc button dm_mod raid10 raid456 async_pq async_xor xor async_memcpy async_raid6_recov raid6_pq async_tx raid1 r
Jul 12 16:48:37 shambhala kernel: aid0 linear md_mod btrfs zlib_deflate crc32c libcrc32c usbhid uhci_hcd sg sr_mod cdrom thermal ehci_hcd usbcore [last unloaded: scsi_wait_scan]
Jul 12 16:48:37 shambhala kernel: Pid: 16124, comm: Xorg Tainted: G      D    2.6.34.1-tp42-toi-3.1.1.1-04990-g3a7d1f4 #3
Jul 12 16:48:37 shambhala kernel: Call Trace:
Jul 12 16:48:37 shambhala kernel: [<c1029cf1>] __schedule_bug+0x61/0x70
Jul 12 16:48:37 shambhala kernel: [<c140549d>] schedule+0x3ed/0x4d0
Jul 12 16:48:37 shambhala kernel: [<c140593e>] _cond_resched+0x2e/0x50
Jul 12 16:48:37 shambhala kernel: [<c10cdd37>] unmap_vmas+0x597/0x5b0
Jul 12 16:48:37 shambhala kernel: [<c100682e>] ? mask_and_ack_8259A+0xde/0x100
Jul 12 16:48:37 shambhala kernel: [<c10d4963>] exit_mmap+0x93/0x170
Jul 12 16:48:37 shambhala kernel: [<c103288b>] mmput+0x3b/0xe0
Jul 12 16:48:37 shambhala kernel: [<c1036dd3>] exit_mm+0xd3/0xf0
Jul 12 16:48:37 shambhala kernel: [<c1037ac5>] do_exit+0x5c5/0x710
Jul 12 16:48:37 shambhala kernel: [<c1006008>] oops_end+0x68/0xa0
Jul 12 16:48:37 shambhala kernel: [<c10061d4>] die+0x54/0x80
[...]

And more than 8 MiB more of them in about 5 seconds which I attach in as bzip2'd text file.

I don't know whether thats related to bug #16376, maybe its a different bug.
Comment 1 Jérôme Glisse 2010-07-13 13:57:01 UTC
Can you reproduce this with lastest Linus 2.6.35 tree ?
Comment 2 Martin Steigerwald 2010-07-16 18:23:28 UTC
I tried a 2.6.35-rc5 kernel, since it froze too (see bug #16376) I just downgraded to 2.6.33.6 again which works for me. I do not like to try again until bug #16376 is solved, since this is still my production laptop.
Comment 3 Alex Deucher 2010-07-16 19:18:00 UTC
Any chance you could bisect this?
Comment 4 Martin Steigerwald 2010-07-16 21:13:12 UTC
Difficult, since I don't know when it happens. Often I do not run two KDE sessions, but I could let two run for testing. But then there is that freeze bug #16376. I'd rather concentrate on that one first. And honestly: In the moment I prefer running 2.6.33.6, since it doesn't freeze ;).
Comment 5 Martin Steigerwald 2010-07-16 21:15:32 UTC
BTW doesn't the backtrace from above help?
Comment 6 Rafael J. Wysocki 2010-08-01 14:18:08 UTC
Handled-By : Alex Deucher <alexdeucher@gmail.com>
Comment 7 Martin Steigerwald 2010-12-07 21:21:50 UTC
I didn't see this with 2.6.36 + various patches regarding bug #16376.

I didn't see this with 2.6.37-rc3 nor rc5.

Thus setting to resolved as unreproducible.

Note You need to log in before you can comment on or make changes to this bug.