Bug 16370 - HDD not suspending properly / dead on resume
HDD not suspending properly / dead on resume
Status: RESOLVED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA
All Linux
: P1 normal
Assigned To: Jeff Garzik
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2010-07-12 15:34 UTC by Maciej Rutecki
Modified: 2010-09-23 23:20 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.35-rc4
Tree: Mainline
Regression: No


Attachments
SATA / AHCI: Do not play with the link PM during suspend to RAM (2.17 KB, patch)
2010-07-25 12:38 UTC, Rafael J. Wysocki
Details | Diff
redo-ipm.patch (41.14 KB, patch)
2010-08-05 16:10 UTC, Tejun Heo
Details | Diff

Description Maciej Rutecki 2010-07-12 15:34:15 UTC
Subject    : HDD not suspending properly / dead on resume
Submitter  : Stephan Diestelhorst <stephan.diestelhorst@amd.com>
Date       : 2010-07-09 15:50
Message-ID : 201007091750.05020.stephan.diestelhorst@amd.com
References : http://marc.info/?l=linux-kernel&m=127869083723980&w=2

This entry is being used for tracking a regression from 2.6.34.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2010-07-12 19:25:56 UTC
The bug is there, but I don't think it's a regression.  Dropping from the list.
Comment 2 Rafael J. Wysocki 2010-07-25 12:38:47 UTC
Created attachment 27245 [details]
SATA / AHCI: Do not play with the link PM during suspend to RAM

This patch appears to fix the problem on my test box.
Comment 3 Tejun Heo 2010-08-05 16:10:45 UTC
Created attachment 27358 [details]
redo-ipm.patch

Does this patch resolve the problem?

Thanks.
Comment 4 Rafael J. Wysocki 2010-09-23 23:20:24 UTC
This should be fixed by commit e2f3d75fc0e4a0d03c61872bad39ffa2e74a04ff .

Note You need to log in before you can comment on or make changes to this bug.