Bug 16361 - KMS not working on Radeon Mobility 3430
KMS not working on Radeon Mobility 3430
Status: CLOSED INVALID
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks: 15310
  Show dependency treegraph
 
Reported: 2010-07-10 13:32 UTC by Ruslan
Modified: 2010-08-01 14:07 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.34.1
Tree: Mainline
Regression: Yes


Attachments
log of non-working kernel 2.6.34-rc1 (63.38 KB, application/octet-stream)
2010-07-15 21:29 UTC, Ruslan
Details
log of working kernel 2.6.33.6 (55.98 KB, application/octet-stream)
2010-07-15 21:30 UTC, Ruslan
Details

Description Ruslan 2010-07-10 13:32:26 UTC
When upgraded to 2.6.34.1 kernel version KMS stopped working on my HP 6830s Laptop. During boot immediately after loading RV620 firmware screen shows garbage and starts to flicker.
With 2.6.33.x versions KMS was working well.
VGA card is: ATI Mobility Radeon 3430
Comment 1 Alex Deucher 2010-07-10 13:59:08 UTC
Can you bisect what commit caused the problem?  Also does 2.6.35 work ok?
Comment 2 Ruslan 2010-07-11 13:44:21 UTC
Currently I have checked this:

2.6.33.6 - works
2.6.34-rc1 - does not work
2.6.35-rc4 - does not work
Comment 3 Ruslan 2010-07-11 15:05:08 UTC
(In reply to comment #1)
> Can you bisect what commit caused the problem?  Also does 2.6.35 work ok?

Currently I have checked this:

2.6.33.6 - works
2.6.34-rc1 - does not work
2.6.35-rc4 - does not work
Comment 4 Ruslan 2010-07-15 07:59:15 UTC
I did bisection. Bad commit is:

9f93ed39804a9cfe10577cfae66059fe6bc6e3a5
Comment 5 Rafał Miłecki 2010-07-15 09:17:11 UTC
commit 9f93ed39804a9cfe10577cfae66059fe6bc6e3a5
Author: Jerome Glisse <jglisse@redhat.com>
Date:   Thu Jan 28 18:22:31 2010 +0100

    drm/radeon/kms: bogus cs recorder utilities

    This add an utilities function radeon_ib_bogus_add which will
    save an ib into a list of ib which can then be dumped using
    debugfs. Once dumped the ib is removed from the list. This
    should allow to save & capute ib for further debugging.

    Signed-off-by: Jerome Glisse <jglisse@redhat.com>
    Signed-off-by: Dave Airlie <airlied@redhat.com>
Comment 6 Rafael J. Wysocki 2010-07-15 11:33:33 UTC
First-Bad-Commit : 9f93ed39804a9cfe10577cfae66059fe6bc6e3a5
Comment 7 Jérôme Glisse 2010-07-15 13:33:11 UTC
I would find very hard to believe that this patch is the root of your issue, did you try to reverse it ? (it should reverse cleanly i think).
Comment 8 Ruslan 2010-07-15 17:07:00 UTC
I am sorry, I posted wrong commit number. I re-checked my bisect process and
correct first bad commit is: d594e46ace22afa1621254f6f669e65430048153
Comment 9 Alex Deucher 2010-07-15 17:47:15 UTC
Can you attach your dmesg?
Comment 10 Jérôme Glisse 2010-07-15 17:55:12 UTC
Working & non working dmesg would be helpfull thanks
Comment 11 Rafael J. Wysocki 2010-07-15 21:11:25 UTC
First-Bad-Commit : d594e46ace22afa1621254f6f669e65430048153
Comment 12 Ruslan 2010-07-15 21:29:54 UTC
Created attachment 27125 [details]
log of non-working kernel 2.6.34-rc1

this is dmesg log of non-working kernel 2.6.34-rc1
Comment 13 Ruslan 2010-07-15 21:30:39 UTC
Created attachment 27126 [details]
log of working kernel 2.6.33.6

dmesg log of working kernel 2.6.33.6
Comment 14 Jérôme Glisse 2010-07-15 21:34:48 UTC
It seems your issue is a missing firmware, you likely forgot to add firmware to
your initramfs or to build them in with the kernel. Try fixing that and also
boot with drm.debug=4 option so we can have more debug informations on
modesetting issue.

You might also want to try radeon.new_pll=0 boot option.
Comment 15 Ruslan 2010-07-15 21:38:24 UTC
I attached two logs: for good and bad kernels.
I just noticed that firmware fails to load in both cases. I never checked this and thought that with 2.6.33.6 it loads successfully.
This means that KMS is not working with my card at all.

But in bad case kernel 2.6.34-rc1 is unable to switch into good video mode after firmware fail.
Comment 16 Ruslan 2010-07-15 21:39:10 UTC
(In reply to comment #14)
> It seems your issue is a missing firmware, you likely forgot to add firmware to
> your initramfs or to build them in with the kernel. Try fixing that and also
> boot with drm.debug=4 option so we can have more debug informations on
> modesetting issue.
> 
> You might also want to try radeon.new_pll=0 boot option.

ok. I will work on this
Comment 17 Ruslan 2010-07-16 11:52:52 UTC
I compiled in firmware into kernel and got KMS working on 2.6.34.1. It was incorrect config. So the problem is that after failed firmware load newer kernels cannot switch into good framebuffer or just plain VGA mode. But I am not sure this can be treated as a bug.

Note You need to log in before you can comment on or make changes to this bug.