Bug 16354 - 2.6.35-rc4 Graphics performance issue and freeing invalid memtype messages on boot.
Summary: 2.6.35-rc4 Graphics performance issue and freeing invalid memtype messages on...
Status: CLOSED CODE_FIX
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64 (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: platform_x86_64@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks: 16055
  Show dependency tree
 
Reported: 2010-07-08 15:54 UTC by Maciej Rutecki
Modified: 2010-07-08 23:39 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.35-rc4
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-07-08 15:54:37 UTC
Subject    : 2.6.35-rc4 Graphics performance issue and freeing invalid memtype messages on boot.
Submitter  : Andrew Hendry <andrew.hendry@gmail.com>
Date       : 2010-07-06 12:22
Message-ID : 1278418937.1949.22.camel@jaunty
References : http://marc.info/?l=linux-kernel&m=127841896332522&w=2

This entry is being used for tracking a regression from 2.6.34.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 andrew.hendry 2010-07-08 23:16:39 UTC
Graphics hardware is NV250 type card.

Some quick testing last night showed this patch fixed both the boot messages and graphics performance.
[tip:x86/urgent] rbtree: Undo augmented trees performance damage and regression
http://marc.info/?l=linux-kernel&m=127833440902862&w=2
Comment 2 Rafael J. Wysocki 2010-07-08 23:39:32 UTC
Fixed by commit b945d6b2554d550fe95caadc61e521c0ad71fb9c .

Note You need to log in before you can comment on or make changes to this bug.