Bug 16353 - 2.6.35 regression
Summary: 2.6.35 regression
Status: CLOSED CODE_FIX
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64 (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: platform_x86_64@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks: 16055
  Show dependency tree
 
Reported: 2010-07-08 15:26 UTC by Maciej Rutecki
Modified: 2010-07-24 22:45 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.35-rc4
Tree: Mainline
Regression: Yes


Attachments
requested dissassembly of kernel compiled with gcc version 4.5.1-pre9999 20100701 (prerelease) rev. 161655 (Gentoo SVN) (49.12 KB, application/octet-stream)
2010-07-08 18:41 UTC, Zeev Tarantov
Details
requested dissassembly of kernel compiled with gcc version 4.4.4 (Gentoo 4.4.4-r1 p1.0, pie-0.4.5) (51.50 KB, application/octet-stream)
2010-07-08 18:44 UTC, Zeev Tarantov
Details

Description Maciej Rutecki 2010-07-08 15:26:54 UTC
Subject    : 2.6.35 regression
Submitter  : Zeev Tarantov <zeev.tarantov@gmail.com>
Date       : 2010-07-05 13:04
Message-ID : loom.20100705T144459-919@post.gmane.org
References : http://marc.info/?l=linux-kernel&m=127836002702522&w=2

This entry is being used for tracking a regression from 2.6.34.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Zeev Tarantov 2010-07-08 18:41:35 UTC
Created attachment 27044 [details]
requested dissassembly of kernel compiled with gcc version 4.5.1-pre9999 20100701 (prerelease) rev. 161655 (Gentoo SVN)
Comment 2 Zeev Tarantov 2010-07-08 18:44:15 UTC
Created attachment 27045 [details]
requested dissassembly of kernel compiled with gcc version 4.4.4 (Gentoo 4.4.4-r1 p1.0, pie-0.4.5)
Comment 3 Rafael J. Wysocki 2010-07-09 21:05:10 UTC
Patch : https://patchwork.kernel.org/patch/110988/
Handled-By : Steven Rostedt <rostedt@goodmis.org>
Comment 4 Zeev Tarantov 2010-07-14 13:00:19 UTC
Maciej Rutecki or Rafael J. Wysocki: Could you please re-open this bug and keep it open until a mainline kernel release or release candidate is out with this fixed? Or at least until a patch for it is committed to mainline? Because although several tested patched are available, rc5 went out without this fixed and I don't see any movement on that front.

Latest was:

http://marc.info/?l=linux-kernel&m=127882846624782&w=2

Sam Ravnborg pledged to have a more comprehensive fix for the entire class of bugs caused by symbol mis-alignment ready for the next merge window, but Steven Rostedt was supposed to get a patch for just this regression committed.
Comment 5 Rafael J. Wysocki 2010-07-14 20:54:49 UTC
The bug hasn't been closed yet and the 'resolved' status means the issue is known and there's a working patch for it.  Once a fix has been merged, the status will be changed to 'closed'.
Comment 6 Chuck Ebbert 2010-07-23 22:56:23 UTC
Fixed by 07fca0e57fca925032526349f4370f97ed580cc9

But I can't seem to close this bug.

Note You need to log in before you can comment on or make changes to this bug.