Bug 16342 - DVB Elgato EyeTV Hybrid (0fd9:0018) not handled by driver
Summary: DVB Elgato EyeTV Hybrid (0fd9:0018) not handled by driver
Status: RESOLVED OBSOLETE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-05 12:21 UTC by Rafał Miłecki
Modified: 2012-08-09 14:18 UTC (History)
2 users (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: No


Attachments
V4L/DVB: dib0700: Add Elgato EyeTV Hybrid usbid (0fd9:0018) (1.75 KB, patch)
2010-07-05 13:44 UTC, Rafał Miłecki
Details | Diff
put EyeTV Hybrid in one group with EyeTV Diversity (1.17 KB, patch)
2010-07-05 13:51 UTC, Rafał Miłecki
Details | Diff

Description Rafał Miłecki 2010-07-05 12:21:59 UTC
AFAIU Elgato's devices should be handled by dib0700. This is not the case for my 0fd9:0018.
Comment 1 Rafał Miłecki 2010-07-05 13:44:47 UTC
Created attachment 27022 [details]
V4L/DVB: dib0700: Add Elgato EyeTV Hybrid usbid (0fd9:0018)

The first, base patch needed for EyeTV Hybrid support. It won't add any real support alone.
Comment 2 Rafał Miłecki 2010-07-05 13:51:45 UTC
Created attachment 27023 [details]
put EyeTV Hybrid in one group with EyeTV Diversity

First idea was to put EyeTV Hybrid in the group where EyeTV Diversity exists. This leads to creating /dev/dvb/adapter0 (and /dev/dvb/adapter1? not sure if I remember correctly now). However using dvbscan doesn't work:

# dvbscan /usr/share/dvb/dvb-t/pl-Wroclaw
Failed to open frontend

# dmesg
[  826.074071] usb 2-2: new high speed USB device using ehci_hcd and address 4
[  826.189882] usb 2-2: New USB device found, idVendor=0fd9, idProduct=0018
[  826.189891] usb 2-2: New USB device strings: Mfr=3, Product=1, SerialNumber=2
[  826.189898] usb 2-2: Product: EyeTV Hybrid
[  826.189903] usb 2-2: Manufacturer: Elgato
[  826.189909] usb 2-2: SerialNumber: 100204003092
[  826.480568] dib0700: loaded with support for 14 different device-types
[  826.480833] dvb-usb: found a 'Elgato EyeTV Hybrid' in warm state.
[  826.480980] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[  826.481545] DVB: registering new adapter (Elgato EyeTV Hybrid)
[  826.518126] dib0700: stk7070pd_frontend_attach0: dib7000p_i2c_enumeration failed.  Cannot continue
[  826.518132]
[  826.518167] dvb-usb: no frontend was attached by 'Elgato EyeTV Hybrid'
[  826.518185] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[  826.518524] DVB: registering new adapter (Elgato EyeTV Hybrid)
[  826.520942] dvb-usb: no frontend was attached by 'Elgato EyeTV Hybrid'
[  826.521151] input: IR-receiver inside an USB DVB receiver as /devices/pci0000:00/0000:00:1d.7/usb2/2-2/input/input10
[  826.521229] dvb-usb: schedule remote query interval to 50 msecs.
[  826.521237] dvb-usb: Elgato EyeTV Hybrid successfully initialized and connected.
[  826.521955] usbcore: registered new interface driver dvb_usb_dib0700
[  826.571246] dib0700: Unknown remote controller key:  1 11  0  0
[  826.621433] dib0700: Unknown remote controller key:  1 11  0  0
[  826.671362] dib0700: Unknown remote controller key:  1 11  0  0
(...)
[  879.661310] dib0700: Unknown remote controller key:  1 11  0  0
[  879.711314] dib0700: Unknown remote controller key:  1 11  0  0
[  879.761311] dib0700: Unknown remote controller key:  1 11  0  0
[  879.792980] usb 2-2: USB disconnect, address 4
[  879.797838] dvb-usb: Elgato EyeTV Hybrid successfully deinitialized and disconnected.
Comment 3 Eddie Lania 2011-06-04 11:15:23 UTC
Can I help in any way by testing?
I do not have development skills.
But I would like to see this device working in Linux badly, because I also have such a device here and can't wait to start using it in Linux.

I think adding support for it to kernel has been taking to much time already.

So, please continue developing support for it.
If i can be of any assistance, please let me know.

Regards,

Eddie.
Comment 4 Eddie Lania 2011-06-26 12:30:51 UTC
From what i found on the internet, the device's specs are:

Model: EU 2008
USB Controller: Empia EM2884
Stereo A/V Decoder: Micronas AVF 49x08
Hybrid Channel Decoder: Micronas DRX-K DRX3926K:A1 0.9.0

I spoke to a few people on the IRC linuxtv channel @freenode and it appears to be a 2884/drxk/avfb combo.
Micronas has allowed a GPL driver to be released.  But nobody has been willing to do the work to get it upstream.
It still needs a couple dozen hours worth of work to get up and running, and deal with all the codingstyle issues, etc.

I hope that someone is willing to do this somewhere in the nearby future.

It's a great device; it can do dvb-c and dvb-t but also has an analogue tuner for tv and radio, and it can capture video/audio from composite/s-video connected devices as well.

I'd love to see this device working in Linux in the future.

Regards,

Eddie.
Comment 5 Eddie Lania 2011-06-26 13:00:20 UTC
There is a message from Markus Rechberger on mcentral; http://www.mail-archive.com/em28xx@mcentral.de/msg01188.html

Maybe he can be contacted about the missing driver and details ?
So it wouldn't be necessary to reinvent the wheel?

To bad I can't program.

Note You need to log in before you can comment on or make changes to this bug.