Bug 16326 - i8042 input not built when X86_MRST is selected
i8042 input not built when X86_MRST is selected
Status: RESOLVED DUPLICATE of bug 16325
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 high
Assigned To: drivers_input-devices
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-02 03:29 UTC by Kenney Phillis Jr.
Modified: 2010-07-02 03:33 UTC (History)
0 users

See Also:
Kernel Version: 2.6.35-rc3
Tree: Mainline
Regression: Yes


Attachments
Testing Results and patch showing the regression. (237.07 KB, application/x-gzip)
2010-07-02 03:29 UTC, Kenney Phillis Jr.
Details

Description Kenney Phillis Jr. 2010-07-02 03:29:04 UTC
Created attachment 26994 [details]
Testing Results and patch showing the regression.

I performed all testing to figure out this regression, and it's all related to the patch.... 0b28bac5aef7bd1ab213723df031e61db9ff151a ... this prevents the i8042 module from being built and used, however a lot of recent devices still use this form of input.

I attached various config files and other things to verify the results... also, in the include attachment is the simple patch required to remove the problems with keyboard input along with various system logs to show what is happening.

also, on a quick note, the testing is against the latest linux-2.6 tree with commit:
9fbd7f9d112e50dc7649d13de37bc92cb50c3905
Comment 1 Kenney Phillis Jr. 2010-07-02 03:33:14 UTC
double bug report.

*** This bug has been marked as a duplicate of bug 16325 ***

Note You need to log in before you can comment on or make changes to this bug.