Bug 16325 - i8042 input regression
i8042 input regression
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 high
Assigned To: drivers_input-devices
:
: 16326 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-02 03:24 UTC by Kenney Phillis Jr.
Modified: 2011-07-18 22:52 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.35-rc3
Tree: Mainline
Regression: Yes


Attachments
Testing Results and patch. (237.07 KB, application/octet-stream)
2010-07-02 03:24 UTC, Kenney Phillis Jr.
Details

Description Kenney Phillis Jr. 2010-07-02 03:24:12 UTC
I performed all testing to figure out this regression, and it's all related to the patch.... 0b28bac5aef7bd1ab213723df031e61db9ff151a ... this prevents the i8042 module from being built and used, however a lot of recent devices still use this form of input.

I attached various config files and other things to verify the results... also, in the include attachment is the simple patch required to remove the problems with keyboard input along with various system logs to show what is happening.

also, on a quick note, the testing is against the latest linus tree with commit:
9fbd7f9d112e50dc7649d13de37bc92cb50c3905
Comment 1 Kenney Phillis Jr. 2010-07-02 03:33:14 UTC
*** Bug 16326 has been marked as a duplicate of this bug. ***
Comment 2 Dmitry Torokhov 2011-07-18 22:52:28 UTC
This has been fixed in mainline.

Note You need to log in before you can comment on or make changes to this bug.