Bug 16311 - [REGRESSION][SUSPEND] 2.6.35-rcX won't suspend Lenovo W500 laptop
[REGRESSION][SUSPEND] 2.6.35-rcX won't suspend Lenovo W500 laptop
Status: CLOSED DUPLICATE of bug 16396
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 7216 16055
  Show dependency treegraph
 
Reported: 2010-06-28 17:39 UTC by Maciej Rutecki
Modified: 2010-07-29 22:56 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.35-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-06-28 17:39:39 UTC
Subject    : [REGRESSION][SUSPEND] 2.6.35-rcX won't suspend Lenovo W500 laptop
Submitter  : Shawn Starr <shawn.starr@rogers.com>
Date       : 2010-06-28 0:45
Message-ID : 201006272045.17004.shawn.starr@rogers.com
References : http://marc.info/?l=linux-kernel&m=127768633705286&w=2

This entry is being used for tracking a regression from 2.6.34.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2010-07-09 21:04:04 UTC
On Friday, July 09, 2010, Shawn Starr wrote:
> On Thursday, July 08, 2010 07:41:40 pm Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a summary report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.34.  Please verify if it still should be listed and let the
> > tracking team know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=16311
> > Subject		: [REGRESSION][SUSPEND] 2.6.35-rcX won't suspend Lenovo W500
> > laptop Submitter	: Shawn Starr <shawn.starr@rogers.com>
> > Date		: 2010-06-28 0:45 (11 days old)
> 
> Continues with July 7th, snapshot of 2.6.35-rc4. 
> 
> Some more info: I have USB in use while trying to suspend.  A USB Microsoft 
> Mouse and a QuickCam Pro 9000 camera connected.
Comment 2 Thomas Meyer 2010-07-17 15:26:53 UTC
Please check if this bug is the same as https://bugzilla.kernel.org/show_bug.cgi?id=16256
Comment 3 Shawn Starr 2010-07-17 17:35:46 UTC
Not related for me. No TPM driver loaded, no TPM enabled in BIOS. I will test this today when I get some spare cycles.
Comment 4 Eric Valette 2010-07-20 13:52:04 UTC
I have similar problem were suspend to ram fails on amilo xi 3650. It also has a an Intel graphic chips using i915.

lspci -v | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller: nVidia Corporation G96 [GeForce 9600M GT] (rev a1) (prog-if 00 [VGA controller])

Note that the second controller is not active at suspend time.
Comment 5 Rafael J. Wysocki 2010-07-20 15:27:46 UTC
On Tuesday, July 20, 2010, Shawn Starr wrote:
> On Monday, July 19, 2010 09:12:08 pm Shawn Starr wrote:
> > On Monday, July 19, 2010 08:33:30 pm Shawn Starr wrote:
> > > On Thursday, July 08, 2010 11:36:25 pm Shawn Starr wrote:
> > > 
> > > <snip>
> > > 
> > > > > > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=16311
> > > > > > Subject         : [REGRESSION][SUSPEND] 2.6.35-rcX won't suspend
> > > > > > Lenovo W500 laptop Submitter       : Shawn Starr
> > > > > > <shawn.starr@rogers.com> Date            : 2010-06-28 0:45 (11 days
> > > > > > old)
> > > > > > Message-ID      : <201006272045.17004.shawn.starr@rogers.com>
> > > > > > References      :
> > > > > > http://marc.info/?l=linux-kernel&m=127768633705286&w=2
> > > > > 
> > > > > I think this might be usefully bisected. Shawn?
> > > > 
> > > > I'll have to try bisecting this weekend. It continues in Linux sh0n.net
> > > > 2.6.35-rc4+ #1 SMP Wed Jul 7 23:58:41 EDT 2010 x86_64 x86_64 x86_64
> > > > GNU/Linux
> > > 
> > > This continues even with no USB devices plugged in. Will try with today's
> > > snapshot build from Linus's tree. If this still happens, I'll see about
> > > bisecting.
> > > 
> > > Thanks,
> > > Shawn.
> > 
> > I also am testing this patch I noticed in anholt's tree, this may be GPU
> > suspend issue.
> > 
> > diff --git a/drivers/gpu/drm/i915/i915_suspend.c
> > b/drivers/gpu/drm/i915/i915_suspend.c
> > index 60a5800..6e20252 100644 (file)
> > --- a/drivers/gpu/drm/i915/i915_suspend.c
> > +++ b/drivers/gpu/drm/i915/i915_suspend.c
> > @@ -602,7 +602,9 @@ void i915_save_display(struct drm_device *dev)
> > 
> >         /* Only save FBC state on the platform that supports FBC */
> >         if (I915_HAS_FBC(dev)) {
> > -               if (IS_GM45(dev)) {
> > +               if (IS_IRONLAKE_M(dev)) {
> > +                       dev_priv->saveDPFC_CB_BASE =
> > I915_READ(ILK_DPFC_CB_BASE);
> > +               } else if (IS_GM45(dev)) {
> >                         dev_priv->saveDPFC_CB_BASE =
> > I915_READ(DPFC_CB_BASE); } else {
> >                         dev_priv->saveFBC_CFB_BASE =
> > I915_READ(FBC_CFB_BASE); @@ -706,7 +708,10 @@ void
> > i915_restore_display(struct drm_device *dev)
> > 
> >         /* only restore FBC info on the platform that supports FBC*/
> >         if (I915_HAS_FBC(dev)) {
> > -               if (IS_GM45(dev)) {
> > +               if (IS_IRONLAKE_M(dev)) {
> > +                       ironlake_disable_fbc(dev);
> > +                       I915_WRITE(ILK_DPFC_CB_BASE, dev_priv-
> > 
> > >saveDPFC_CB_BASE);
> > 
> > +               } else if (IS_GM45(dev)) {
> >                         g4x_disable_fbc(dev);
> >                         I915_WRITE(DPFC_CB_BASE,
> > dev_priv->saveDPFC_CB_BASE); } else {
> 
> 
> Made no difference, today's git snapshot, 2.6.35-rc5-git4 w/ airlied + anholt 
> drm git trees still hangs attempting to suspend. in Fedora, it drops to the 
> Fedora logo w/ KMS mode then fails to finish suspending (moon light flashes 
> off and on), I do hear the disk heads parking though.
Comment 6 Eric Valette 2010-07-20 15:45:22 UTC
(In reply to comment #4)
> I have similar problem were suspend to ram fails on amilo xi 3650. It also has
> a an Intel graphic chips using i915.
> 
> lspci -v | grep VGA
> 00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset
> Integrated Graphics Controller (rev 07) (prog-if 00 [VGA controller])
> 01:00.0 VGA compatible controller: nVidia Corporation G96 [GeForce 9600M GT]
> (rev a1) (prog-if 00 [VGA controller])
> 
> Note that the second controller is not active at suspend time.

Forgot to say it hangs during *shutdown* stage not even during wakeup. It starts lockscreen, then switch to console, and I get a blinking cursor on top of the newly switched console and then the FAN starts and the machine is dead. Do not get the blinking power off button I normally have.
Comment 7 Eric Valette 2010-07-29 13:47:06 UTC
Retested this afternoon with 2.6.35-rc6-git4. No change. I already have seen reports on tree laptops form different vendors (IBM, fujitsu, HP) that are failing to suspend with exactly the same symptoms. IMHO many laptop user may be disappointed if 2.6.35 gets out and the bug is still there as we may discover many more brand and model at that time...
Comment 8 Eric Valette 2010-07-29 13:59:44 UTC
Command line: BOOT_IMAGE=linuxTest ro root=812 acpi_sleep=nonvs

Makes it work, so for me it is clear that storing NVS state even when entering suspend to RAM is causing the lockup.

So IMHO either make it the default state to avoid unexpected regression when 2.6.35 is released or fix the NVS state strage it so that it works  before 2.6.35
Comment 9 Eric Valette 2010-07-29 14:32:01 UTC
Command line: BOOT_IMAGE=linuxTest ro root=812 acpi_sleep=nonvs

Makes it work, so for me it is clear that storing NVS state even when entering suspend to RAM is causing the lockup.

So IMHO either make it the default state to avoid unexpected regression when 2.6.35 is released or fix the NVS state strage it so that it works  before 2.6.35
Comment 10 Rafael J. Wysocki 2010-07-29 22:55:22 UTC
This is a duplicate of bug #16396, let's use that bug to track it from now on, please.

*** This bug has been marked as a duplicate of bug 16396 ***

Note You need to log in before you can comment on or make changes to this bug.