Bug 16310 - arm omap invalid module format
arm omap invalid module format
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: ARM
All Linux
: P1 normal
Assigned To: linux-arm-kernel@lists.arm.linux.org.uk
:
Depends on:
Blocks: 16055
  Show dependency treegraph
 
Reported: 2010-06-28 17:30 UTC by Robert Nelson
Modified: 2010-08-29 22:55 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.35-rc3
Tree: Mainline
Regression: Yes


Attachments
fix (1.06 KB, patch)
2010-07-02 11:28 UTC, Michal Marek
Details | Diff

Description Robert Nelson 2010-06-28 17:30:35 UTC
Between 2.6.35-rc1 to 2.6.35-rc3 external kernel modules stopped loading.

Started a Bisected between 2.6.35-rc1 (good) and 2.6.35-rc2 (bad)...
Stopped at commit: d0679c730395d0bde9a46939e7ba255b4ba7dd7c, which was merged after rc1

Merge: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=1f73897861b8ef0be64ff4b801f8d6f830f683b5

Commit: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=d0679c730395d0bde9a46939e7ba255b4ba7dd7c

Debian Squeeze
voodoo@beagle-256mb-1:~$ gcc --version
gcc (Debian 4.4.4-5) 4.4.4

2.6.35-rc3:

voodoo@beagle-256mb-1:~$ lsmod
Module                  Size  Used by

voodoo@beagle-256mb-1:~$ sudo modprobe asix
[   36.665161] asix: unknown relocation: 3
FATAL: Error inserting asix (/lib/modules/2.6.35-rc3-d1/kernel/drivers/net/usb/asix.ko): Invalid module format

2.6.35-rc3 with "d0679c730395d0bde9a46939e7ba255b4ba7dd7c" reverted:

voodoo@beagle-256mb-1:~$ lsmod
Module                  Size  Used by
asix                   12870  0 
mailbox_mach            4323  0 
rtc_twl                 4375  0 
mailbox                 3473  1 mailbox_mach
rtc_core               13385  1 rtc_twl

Looks like arm needs the same patch as powerpc..

Regards,
Comment 1 Rafael J. Wysocki 2010-06-30 23:38:02 UTC
First-Bad-Commit : d0679c730395d0bde9a46939e7ba255b4ba7dd7c
Comment 2 Michal Marek 2010-07-02 11:28:17 UTC
Created attachment 26999 [details]
fix

Robert, does this fix work for you?

Russel, is the patch OK (do all arm flavors need the workaround or just some)? Should this go through the kbuild tree or the arm tree?
Comment 3 Robert Nelson 2010-07-02 22:42:14 UTC
Hi Michal,

Applied patch to 2.6.35-rc3, it fixes module issue.. Built and run tested on target Omap3530 ARM board.
Comment 4 Rafael J. Wysocki 2010-07-08 23:30:39 UTC
Handled-By : Michal Marek <mmarek@suse.cz>
Patch : https://bugzilla.kernel.org/attachment.cgi?id=26999
Comment 5 Rafael J. Wysocki 2010-08-29 22:55:16 UTC
Fixed by commit bd365591dfb942d1447b8043e21e8ff112630db4 .

Note You need to log in before you can comment on or make changes to this bug.