Bug 16290 - Webcam only offers lower resolutions
Webcam only offers lower resolutions
Status: RESOLVED OBSOLETE
Product: v4l-dvb
Classification: Unclassified
Component: webcam
All Linux
: P1 normal
Assigned To: webcam
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-25 08:27 UTC by Vish
Modified: 2012-08-09 14:11 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.34 , 2.6.35
Tree: Mainline
Regression: No


Attachments
lspci -vvnn (14.22 KB, text/plain)
2010-06-25 08:27 UTC, Vish
Details
lsusb (433 bytes, text/plain)
2010-06-25 08:28 UTC, Vish
Details
dmesg (57.08 KB, text/plain)
2010-06-25 08:30 UTC, Vish
Details

Description Vish 2010-06-25 08:27:31 UTC
Created attachment 26941 [details]
lspci -vvnn

In Acer Aspire 5670 the built-in webcam is a 1.3 megapx one, while the resolutions offered are only qvga (320x240) and vga (640x480).

This is not a regression , but since the new drivers are being added as mentioned in > https://bugzilla.kernel.org/show_bug.cgi?id=16077#c5 .
Considered filing a bug.

~$ uname -a
Linux vish-laptop 2.6.35-999-generic #201006151505 SMP Tue Jun 15 15:21:41 UTC 2010 i686 GNU/Linux

~$ v4l-info

### v4l2 device info [/dev/video0] ###
general info
    VIDIOC_QUERYCAP
	driver                  : "vc032x"
	card                    : "Camera"
	bus_info                : "usb-0000:00:1d.7-8"
	version                 : 2.9.0
	capabilities            : 0x5000001 [VIDEO_CAPTURE,READWRITE,STREAMING]

standards

inputs
    VIDIOC_ENUMINPUT(0)
	index                   : 0
	name                    : "vc032x"
	type                    : CAMERA
	audioset                : 0
	tuner                   : 0
	std                     : 0x0 []
	status                  : 0x0 []

video capture
    VIDIOC_ENUM_FMT(0,VIDEO_CAPTURE)
	index                   : 0
	type                    : VIDEO_CAPTURE
	flags                   : 0
	description             : "YVYU"
	pixelformat             : 0x55595659 [YVYU]
    VIDIOC_G_FMT(VIDEO_CAPTURE)
	type                    : VIDEO_CAPTURE
	fmt.pix.width           : 640
	fmt.pix.height          : 480
	fmt.pix.pixelformat     : 0x55595659 [YVYU]
	fmt.pix.field           : NONE
	fmt.pix.bytesperline    : 640
	fmt.pix.sizeimage       : 614400
	fmt.pix.colorspace      : SRGB
	fmt.pix.priv            : 0

controls
    VIDIOC_QUERYCTRL(BASE+0)
	id                      : 9963776
	type                    : INTEGER
	name                    : "Brightness"
	minimum                 : 0
	maximum                 : 255
	step                    : 1
	default_value           : 128
	flags                   : 0
    VIDIOC_QUERYCTRL(BASE+1)
	id                      : 9963777
	type                    : INTEGER
	name                    : "Contrast"
	minimum                 : 0
	maximum                 : 255
	step                    : 1
	default_value           : 127
	flags                   : 0
    VIDIOC_QUERYCTRL(BASE+2)
	id                      : 9963778
	type                    : INTEGER
	name                    : "Saturation"
	minimum                 : 1
	maximum                 : 127
	step                    : 1
	default_value           : 63
	flags                   : 0

### video4linux device info [/dev/video0] ###
general info
    VIDIOCGCAP
	name                    : "Camera"
	type                    : 0x1 [CAPTURE]
	channels                : 1
	audios                  : 0
	maxwidth                : 640
	maxheight               : 480
	minwidth                : 48
	minheight               : 32

channels
    VIDIOCGCHAN(0)
	channel                 : 0
	name                    : "vc032x"
	tuners                  : 0
	flags                   : 0x0 []
	type                    : CAMERA
	norm                    : 0

tuner
ioctl VIDIOCGTUNER: Invalid argument

audio
    VIDIOCGAUDIO
	audio                   : 0
	volume                  : 0
	bass                    : 0
	treble                  : 0

picture
    VIDIOCGPICT
	brightness              : 32896
	hue                     : 0
	colour                  : 32247
	contrast                : 32639
	whiteness               : 0
	depth                   : 8
	palette                 : unknown

buffer
ioctl VIDIOCGFBUF: Invalid argument

window
    VIDIOCGWIN
	x                       : 0
	y                       : 0
	width                   : 640
	height                  : 480
	chromakey               : 0
	flags                   : 0
Comment 2 Vish 2010-06-25 08:30:14 UTC
Created attachment 26943 [details]
dmesg
Comment 3 Vish 2010-06-26 10:17:37 UTC
From https://bugzilla.kernel.org/show_bug.cgi?id=16270#c9
> I also added a 1280x1024 mode, but it is the one for an other webcam. It may
> work... (from your traces, the ms-win driver knows only 300K pixels: the images
> are always 640x480).

Yeah , I thought something was wrong when the window didnt resize for the larger sizes! the windows partition was re-installed. Maybe the wrong drivers were installed. I'll try to find the right drivers and see if i can get new traces.

But the 1280x1024 didnt work either , it causes a horizontally cut image which stutters and has a dark green tint on the lower half.
Comment 4 Vish 2010-06-26 10:19:40 UTC
With these errors at times:

Jun 26 15:37:49 vish-laptop kernel: [  391.855609] gspca-2.9.45: ISOC data error: [12] len=1024, status=-71
Jun 26 15:38:05 vish-laptop kernel: [  407.987624] gspca-2.9.45: ISOC data error: [57] len=1024, status=-71
Jun 26 15:44:50 vish-laptop kernel: [  812.635584] gspca-2.9.45: ISOC data error: [9] len=1024, status=-71
Jun 26 15:45:13 vish-laptop kernel: [  835.899634] gspca-2.9.45: ISOC data error: [91] len=1024, status=-71
Comment 5 Jean-Francois Moine 2010-07-01 18:15:27 UTC
(In reply to comment #3)
> But the 1280x1024 didnt work either , it causes a horizontally cut image which
> stutters and has a dark green tint on the lower half.

This may mean that the bridge vc0321 cannot handle images bigger than 640x480...
Comment 6 Vish 2010-07-02 21:04:28 UTC
(In reply to comment #5)
> (In reply to comment #3)
> > But the 1280x1024 didnt work either , it causes a horizontally cut image which
> > stutters and has a dark green tint on the lower half.
> 
> This may mean that the bridge vc0321 cannot handle images bigger than
> 640x480...

I get these stutters , cut line during 640x480 mode too , but it is rare.[dont get the green tint on half picture though] .

With the 1280x1024 , this happens almost all the time.
Comment 7 Jean-Francois Moine 2010-09-02 08:41:39 UTC
I added back the 1280x1024 resolution in gspca-2.10.9 for your webcam with the po3130nc sensor. Have you the same result?
Comment 8 Vish 2010-09-03 21:46:51 UTC
(In reply to comment #7)
> I added back the 1280x1024 resolution in gspca-2.10.9 for your webcam with the
> po3130nc sensor. Have you the same result?

Yup, i tried the new driver too. Its the same stuttering as observed earlier.
Also, seeing that since we are now using the driver from .33 kernel , the 640x480 is also stuttering as i had mentioned earlier on the other bug. [which was expected.] But the two stuttering differ. 640x480 had various cut lines and keeps repeating , but in the 1280x1024 , the image is cut in half and stutters the same more of two static frames. And the frames change only at very long intervals

Note You need to log in before you can comment on or make changes to this bug.