Bug 16288 - kernel panic with iwlagn for Intel Wifi Link 5100
Summary: kernel panic with iwlagn for Intel Wifi Link 5100
Status: CLOSED UNREPRODUCIBLE
Alias: None
Product: Networking
Classification: Unclassified
Component: Wireless (show other bugs)
Hardware: All Linux
: P1 blocking
Assignee: networking_wireless@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks: 16055
  Show dependency tree
 
Reported: 2010-06-25 08:14 UTC by yanshuang.zheng
Modified: 2010-07-23 11:15 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.35
Tree: Mainline
Regression: Yes


Attachments
Screenshot - kernel panic (866.73 KB, image/jpeg)
2010-06-27 02:04 UTC, yanshuang.zheng
Details

Description yanshuang.zheng 2010-06-25 08:14:09 UTC
When starting installation OS based on kernel-2.6.35 with Intel wifi link 5100(driver in use: iwlagn) plugged, it immediately runs into kernel panic.

If unplug the wifi card, the installation can be started successfully. 

This is NOT found on kernel-2.6.34 and before.
Comment 1 John W. Linville 2010-06-26 15:15:42 UTC
Perhaps you could capture the console message?  Even a digital picture of the screen would be helpful.
Comment 2 yanshuang.zheng 2010-06-27 02:04:16 UTC
Created attachment 26958 [details]
Screenshot - kernel panic
Comment 3 John W. Linville 2010-06-28 15:03:36 UTC
Hard to tell, but that looks like grub to me.  Are you sure the kernel has even been loaded yet?
Comment 4 Reinette Chatre 2010-06-28 17:01:02 UTC
(In reply to comment #3)
> Hard to tell, but that looks like grub to me.  Are you sure the kernel has
> even
> been loaded yet?

... please also remove the "quiet splash" from your boot command line so that we can see the full panic.
Comment 5 Rafael J. Wysocki 2010-06-29 09:11:33 UTC
Handled-By : Reinette Chatre <reinette.chatre@intel.com>
Comment 6 yanshuang.zheng 2010-07-09 07:17:27 UTC
 I found this with kernel-2.6.35~rc3-118, but NOT any more with kernel-2.6.35~rc3-121.

Note You need to log in before you can comment on or make changes to this bug.