Bug 16284 - Hitting WARN_ON in hw_breakpoint code
Hitting WARN_ON in hw_breakpoint code
Status: CLOSED WILL_FIX_LATER
Product: Platform Specific/Hardware
Classification: Unclassified
Component: PPC-64
All Linux
: P1 normal
Assigned To: Anton Blanchard
:
Depends on:
Blocks: 16055
  Show dependency treegraph
 
Reported: 2010-06-24 15:33 UTC by Maciej Rutecki
Modified: 2010-07-09 21:39 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.35-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-06-24 15:33:13 UTC
Subject    : Hitting WARN_ON in hw_breakpoint code
Submitter  : Paul Mackerras <paulus@samba.org>
Date       : 2010-06-23 12:57
Message-ID : 20100623125740.GA3368@brick.ozlabs.ibm.com
References : http://marc.info/?l=linux-kernel&m=127729789113432&w=2

This entry is being used for tracking a regression from 2.6.34.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2010-07-09 21:38:14 UTC
On Friday, July 09, 2010, Frederic Weisbecker wrote:
> On Thu, Jul 08, 2010 at 06:34:25PM -0700, Linus Torvalds wrote:
> > On Thu, Jul 8, 2010 at 4:33 PM, Rafael J. Wysocki <rjw@sisk.pl> wrote:
> > > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=16284
> > > Subject         : Hitting WARN_ON in hw_breakpoint code
> > > Submitter       : Paul Mackerras <paulus@samba.org>
> > > Date            : 2010-06-23 12:57 (16 days old)
> > 
> > This has "I have a fix, will post it very soon." in the thread from
> > Frederic, but I'm not seeing anything else. Frederic?
> 
> 
> 
> Right. In fact it wasn't a regression. The per task breakpoint reservation
> design was broken from the beginning and this warning has revealed the
> problem. This only touched perf, and it did since perf support breakpoints.
> Fortunately ptrace wasn't concerned by this problem, even not by side effects
> of this.
> 
> The fix is invasive as it's a rewrite of a (little) part of the breakpoint
> reservation. And since the symptom is only a warning and also breakpoints
> never released from the constraint table (just a counter, no memory leak),
> the fix is headed for 2.6.36.
> 
> It is ready in tip:/perf/core:
> 
> http://git.kernel.org/?p=linux/kernel/git/tip/linux-2.6-tip.git;a=commitdiff;h=45a73372efe4a63f44aa2e1125d4a777c2fdc8d8
> 
> I think this ticket can be safely closed.

Note You need to log in before you can comment on or make changes to this bug.