Bug 16272 - switching to 2.6.34 broke audio on toshiba satellite x205-s9800 using snd_hda_intel module
switching to 2.6.34 broke audio on toshiba satellite x205-s9800 using snd_hda...
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA)
All Linux
: P1 high
Assigned To: Jaroslav Kysela
:
Depends on:
Blocks: 15310
  Show dependency treegraph
 
Reported: 2010-06-22 21:48 UTC by wiggyxoxox
Modified: 2010-09-10 10:05 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.34
Tree: Mainline
Regression: Yes


Attachments
dmesg (47.99 KB, application/octet-stream)
2010-06-22 21:49 UTC, wiggyxoxox
Details
Fix patch (1.74 KB, patch)
2010-06-23 07:58 UTC, Takashi Iwai
Details | Diff

Description wiggyxoxox 2010-06-22 21:48:42 UTC
I switched from 3.6.33 on both sabayon and archlinux distros and both suffer the same symptom of no audio.

alsaconf yeilds:
Loading driver...
:: Saving ALSA Levels [BUSY]
/usr/sbin/alsactl: save_state:1504: No soundcards found.. [DONE]
:: Restoring ALSA Levels [BUSY]
/usr/sbin/alsactl: load_state:1610: No soundcards found...... [FAIL]
Setting default volumes...
amixer: Mixer attach default error: No such file or directory
---------
and if I try to force it by adding snd_hda_intel to modules I hang on boot.
also going to attach dmesg ........
reinstalled 3.6.33 and problem is gone, went back to 3.6.34 and broken.

after no luck fixing it on archforum I was told to post it "upstream" so here it is.

thanks for all of the work you do.
let me know if any more info is required.
Comment 1 wiggyxoxox 2010-06-22 21:49:42 UTC
Created attachment 26903 [details]
dmesg
Comment 2 Takashi Iwai 2010-06-23 07:56:40 UTC
The fix is already in sound git tree and in the pull request (including cc to stable tree).
Comment 3 Takashi Iwai 2010-06-23 07:58:03 UTC
Created attachment 26912 [details]
Fix patch
Comment 4 wiggyxoxox 2010-06-23 17:45:17 UTC
sweet.... Im a n00b so dont exactly know what that means lol.

Is the patch going to be in a revision of 2.6.34 or in .35 when its released???

I made a request with my distro to see if I could get the patch included in their kernel since I dont know how to apply it.
Comment 5 Takashi Iwai 2010-06-23 19:32:26 UTC
It's already in sound git tree, but not in 2.6.35 just because Linus is on vacation.  It'll hit to 2.6.34 stable tree later once after it's merged to 2.6.35.
Comment 6 Rafael J. Wysocki 2010-07-09 22:54:41 UTC
Fixed by commit fbe618f216830f47b183858c3380d4767b1ad02f .
Comment 7 Peter 2010-09-10 10:05:59 UTC
Please tell me, will it be appeared in 2.6.36?

Note You need to log in before you can comment on or make changes to this bug.